Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How can I disable bells/visualbells in vim?

I've tried:

set noeb
set novb

.. but nothing has changed afaik.

Just to be clear, I'm referring to the visual bell I get in vim when I do something that doesn't do anything, for exmaple pressing ESC in normal mode, or pressing h in on col 0.

share|improve this question
add comment

1 Answer

To disable the bell altogether, you need to

  • enable vim's internal visual bell¹, with set visualbell (= set vb);
  • set the effect of the vim visual bell to do nothing, with set t_vb=

(This is explained in the documentation of 'visualbell', but not very clearly.)

¹ Even with novisualbell, you might see a visual bell if vim emits a bell control sequence (usually \a) and the terminal is configured to flash rather than make a sound.

share|improve this answer
    
Note that you'll have to add 'set t_vb=' to your .gvimrc as well if you're using gvim. –  Sverre Rabbelier May 18 '11 at 0:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.