Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

My debian computer will not install the new kernel. It says I have unmet dependencies, and those dependencies say they have unmet dependencies. Many of these dependencies are already installed however. Running apt-get update, apt-get upgrade, and apt-get install -f do not fix the problem. My sources list is as follows:

deb stable main contrib non-free
deb-src stable main contrib non-free

deb squeeze-updates main contrib non-free
deb-src squeeze-updates main contrib non-free

deb squeeze/updates main contrib non-free
deb-src squeeze/updates main contrib non-free

# Debian Squeeze Backports
deb squeeze-backports main contrib non-free
deb-src squeeze-backports main contrib non-free

I've tried installing from the sqeeze-backports and still no luck. Do you guys know what might be going on?

Thanks for the help :)

share|improve this question
grab the dependency errors, drop them in a paste bin for us all to see? – lwm Oct 28 '12 at 11:31
Maybe purge them and reinstall? – Vorac Oct 30 '12 at 7:16

1 Answer 1

up vote 1 down vote accepted

If you want to install from squeeze-backports, you should tell it to apt-get with the -t parameter, and specify the version of the package you want, i.e.:

apt-get install -t squeeze-backports <package-name>=<version>

In order to know which version is provided by a given repository, you can use the apt-cache show command, and look for the info of the package in that repository.

In your case, the command should be:

apt-get install -t squeeze-backports linux-image-2.6-amd64=3.2+45~bpo60+1

for an linux amd64 kernel.

Of course, you may have to run the usual apt-get update first, and if a new kernel package has been uploaded, you might have to replace 3.2+45~bpo60+1 with the new package version.

If you want to install the 3.2 kernel, then the command is:

apt-get install -t squeeze-backports linux-image-3.2.0-0.bpo.3-amd64=3.2.23-1~bpo60+2

but you might omit the version number if you don't have any other repository hosting that kernel in your source list (ie, you don't have testing or unstable).

share|improve this answer
I ended up figuring it out, I had some weird issues going on with firmware, but got it all fixed. Thanks for the help :) – Scriptonaut Nov 3 '12 at 21:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.