Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So I downloaded the non-free broadcom driver(b44) for my debian install, however when I try to make it I get the following error:

make
make -C /lib/modules/2.6.32-5-amd64/build SUBDIRS=/home/scroty/workplace/b44-1.00g modules
make: *** /lib/modules/2.6.32-5-amd64/build: No such file or directory. Stop.
make: *** [default] Error 2

So I looked up my errors, and some other guy here had the same thing, and he fixed it by installing the kernel headers. So I try to do the same, and this is what happens:

sudo apt-get install linux-headers-2.6.32-5-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-headers-2.6.32-5-amd64 : Depends: gcc-4.3 but it is not going to be installed
E: Broken packages

When I try to install gcc-4.3 it's the same thing, except with several more dependencies(some of which I know I have). When I run:

dpkg --get-selections | grep gcc

it returns:

gcc
gcc-4.3-base
gcc-4.4-base
gcc-4.7
gcc-4.7-base
libgcc1

So I have to admit, I'm a huge noob at linux, and have only started to seriously use it(I've used it for years, but not very often) in the past month. So is it bad that I have several different versions of the same package? Is there any reason I shouldn't just delete gcc-4.3 and gcc-4.4 since I have 4.7? I'm having a bit of trouble completely understanding the whole package system.

Thanks a lot guys, feel free to ask me to clarify anything.

EDIT: Does the '32' in 'linux-headers-2.6.32-5-amd64' mean that it's meant for 32bit machiens? Because I'm running 64bit, however I figured 32bit apps would still run.

share|improve this question
1  
The .32 is just part of the version number, it doesn't have anything to do with 32 or 64 bit. –  qqx Oct 27 '12 at 2:37
    
Ah alright, thanks for the info. Do you have any idea what might be going on here? Apt-get just doesn't want to work anymore. Doesn't apt-get automatically find and include dependencies? –  Scriptonaut Oct 27 '12 at 2:38
1  
Try running apt-get update, then try the original apt-get install command again. Dependencies should be installed automatically, if they're not that suggests that your package lists might be out of date. –  qqx Oct 27 '12 at 2:40
1  
What version of debian are you running? –  qqx Oct 27 '12 at 2:43
1  
By package lists, I meant the ones that get updated by running apt-get update, too large to post and unlikely to be helpful. The list of sources might be informative if there's anything unusual in them. –  qqx Oct 27 '12 at 2:48
show 4 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.