Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed vsftpd yesterday on CentOS 6, however didn't get a chance to test it today. When I went to upload a test file it's coming back and giving me this error:

553 Could not create file

After some quick googling the information I found on resolving the error, including this post were already things I tried...

  • Confirm user that is connecting to FTP is a part of the group that owns the directory
  • Confirm the vsftpd.conf file has write_enable set to true

I even went so far as to test changing the group on the whole path down to the destination folder.

EDIT:

Just to expand on this, at the time I did ensure that the modes on the directories were set appropriately as well.

What I ended up doing was uninstalling vsftpd and re-installing from yum. After I did this things worked appropriately. So I'm convinced it was a setting in vsftpd.conf file. However I didn't save a copy of it to do a diff off of to confirm.

Hopefully someone else who has had the same problem with the same symptoms and found out what the cause was can accurately answer this question here for someone else who comes along.

share|improve this question
add comment

2 Answers 2

That group should have rwx permissions on that folder. If not run

chmod 775 <directory>
share|improve this answer
    
While technically correct, and I should edit the original question to highlight this, this did not resolve the issue at the time either. What I ended up doing was uninstalling vsftpd, and reinstalling through yum again. After that everything worked appropriately. Leading me to believe that the issue was in the conf file somewhere. However I unfortunately didn't save the original vsftpd.conf to do a diff between the two. –  Mike Keller Nov 8 '12 at 4:05
add comment

You need to run the following commands to allow in SELinux upload and edit files:

setsebool -P allow_ftpd_full_access on
setsebool -P ftp_home_dir on
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.