Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to make work my wireless network card Intel 2200BG in my laptop Acer Travelmate 4002WLMI.

I tried so far:

$ sudo lshw -C network
*-network:1
       description: Wireless interface
       product: PRO/Wireless 2200BG [Calexico2] Network Connection
       vendor: Intel Corporation
       physical id: 4
       bus info: pci@0000:02:04.0
       logical name: eth1
       version: 05
       serial: 00:0e:35:b0:a7:88
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.5.27 (Dec 12 2007) latency=64 link=no maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
       resources: irq:10 memory:d0208000-d0208fff

$ sudo modprobe ipw2200 
$ dmesg | grep ipw
[   12.087836] libipw: 802.11 data/management/control stack, git-1.1.13
[   12.087839] libipw: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
[   12.209561] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[   12.209566] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[   12.335295] ipw2200 0000:02:04.0: PCI INT A -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
[   12.335329] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[   12.652808] ipw2200: Radio Frequency Kill Switch is On:
[   12.667645] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
[   55.212245] ipw2200: Failed to send POWER_MODE: Command timed out.
[   57.368256] ipw2200: Failed to send POWER_MODE: Command timed out.

or

sudo apt-get install linux-headers-$(uname -r) build-essential
wget http://aceracpi.googlecode.com/files/acer_acpi-0.11.1.tar.bz2
tar -xvjf acer_acpi-0.11.1.tar.bz2
cd acer_acpi-0.11.1
sudo make # this command never ends

or to search here

useful information:

$ uname -r
3.2.0-24-generic

$ sudo rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

distribution : Ubuntu 12.04 LTS

Do you know how to solve this? Should I further try to get my wireless card work or is this hopeless and I should give this up?

share|improve this question
    
Did you update the Makefile as instructed in the INSTALL file? What kernel are you using? –  slafat01 Oct 26 '12 at 15:19
    
@slafat01 completed in question. –  xralf Oct 27 '12 at 11:04
    
Has this wirelless card worked ever in this notebook? Maybe under different OS? Also did you try another Linux distributions? I like OpenSUSE very much... –  George Gaál Nov 8 '12 at 23:48
    
@George Yes, it worked a few years ago on Windows XP. –  xralf Nov 9 '12 at 9:50
add comment

2 Answers

up vote 2 down vote accepted
+150

ipw2200 cards should work just fine under Linux (judging from your kernel you run Ubuntu?). The driver is correct too and it seems not to complain about missing firmware either (you should have some files in /lib/firmware/ called ipw2*.ko).

I remember an old TravelMate (with the same Intel card) had a hardware switch to turn off the WiFi. Even if rfkill reports "no", did you check it?

BTW, you do not need aceracpi, your kernel should have acer-wmi which is the in-kernel successor of aceracpi.

share|improve this answer
    
First place I have stuck - there is no file *.ko in my lib/firmware directory. –  xralf Nov 6 '12 at 9:37
    
That's because I lied :), the files should be *.fw -- sorry. –  zhenech Nov 6 '12 at 16:52
    
OK :-) These are the files ipw2100-1.3.fw ipw2100-1.3-i.fw ipw2100-1.3-p.fw ipw2200-bss.fw ipw2200-ibss.fw ipw2200-sniffer.fw –  xralf Nov 6 '12 at 20:16
    
I tried to use this wiki, maybe it will work. I will ask another question for my problem –  xralf Nov 11 '12 at 17:56
    
Your answer helped me to focus on ipw2200 so, I'm accepting it. Though I try to solve related problems here. Thanks –  xralf Nov 13 '12 at 9:02
add comment

You are not using the right driver

Which kernel driver is your wireless card relying on? Everything from your log seems indicates that you are using ipw, which, according to this wikipedia page, is suitable for Intel PRO/Wireless 2100, but not for Intel 2200 BG. Try using iwi.

As a side note, from what I read in your log: Radio Frequency Kill Switch is On. Have you installed rfkill and checked the current status of the switch? Documentation here.

share|improve this answer
    
I edited the question. Could you please write more about the downloading and installation of iwi? –  xralf Oct 27 '12 at 11:09
    
ipw2200 is the correct driver for Intel Wireless 2200bg. I've used this driver on ibm thinkpad t42 with such wifi adapter and haven't noticed any problem. –  George Gaál Nov 9 '12 at 14:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.