Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have xdg users configured manually, in ~/.config/user-dirs.dirs I have:

XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Various"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/"
XDG_DOCUMENTS_DIR="$HOME/Papers/"
XDG_MUSIC_DIR="/Misc/Musics/"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="/Application/Videos/"

But nautilus just don't show the Desktop folder,

enter image description here

How should I fix that ?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

In GNOME 3, Nautilus no longer manages the DESKTOP. In other words, there is no DESKTOP hence XDG_DESKTOP_DIR is meaningless to Nautilus. You'll have to re-enable the DESKTOP in order to have it among other Nautilus bookmarks in the side pane, either through Gnome-tweak-tool:

Have file manager handle the desktop [ON]

or, in terminal:

gsettings set org.gnome.desktop.background show-desktop-icons true

gsettings set org.gnome.desktop.background draw-background true

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.