Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My RHN Satellite (Spacewalk) server is having issues with monitoring. The Spacewalk Monitor Scout will not push out successfully. It always stops with a Request Expired status. I can't seem to find any error logs. I don't believe that it is a firewall or SELinux issue.

I can run /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes computername /bin/sh -s

And get results back from the client machine. But from the web console the scout expires. In addition, all of my monitor probes are stuck in an Awaiting Update status. The Spacewalk server public key is in the correct location on all clients /var/lib/nocpulse/.ssh/authorized-keys. I'm kind of at a loss. Any help is appreciated.

share|improve this question
    
any takers on this one? –  midnightsteel Nov 9 '12 at 20:08
    
Have you done a service iptables stop and a setenforce 0 and then tried to see if it would work? –  sparticvs Dec 4 '12 at 3:10
    
SELinux and the firewall are not running on both the client and the server –  midnightsteel Dec 4 '12 at 15:04
    
I am not that familiar with RHN Satellite. But i would do an strace -fp on the PID of that monitor to see what is going wrong. Is there really nothing in /var/log/messages about the problem? Are you running this in a VM with limited RAM-resources? –  Nils Dec 5 '12 at 20:58
    
It is a physical server Dual Core 2.8 Ghz, 4GB RAM, 250GB HDD. When I run the command, nothing is returned, no error, no output –  midnightsteel Dec 6 '12 at 14:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.