Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

The following is my route output. eth0 is my wired network and eth1 is my wireless network. Only wired one has access to internet. If I enable wireless, I am not able to access internet, it tries to access via eth1 and I get 404 page of the wireless router. Why does eth1 have higher preference though default is eth0 (link)?

[balakrishnan@mylap ~]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.26.0.1       0.0.0.0         UG    0      0        0 eth0
10.26.0.0       *               255.255.192.0   U     1      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
192.168.1.0     *               255.255.255.0   U     9      0        0 eth1


[balakrishnan@mylap ~]$ tracepath -n 8.8.8.8
 1:  10.26.21.101                                          0.098ms pmtu 1500
 1:  10.26.0.1                                            35.519ms 
 1:  10.26.0.1                                            29.763ms 
 2:  113.193.0.209                                        29.718ms 
 3:  no reply
 4:  no reply
 5:  no reply

Edit: I noticed that some times (rarely) I am able to connect. It looks like it randomly tries on both interfaces. Is there a way to set to use only eth0 ?

share|improve this question
    
The default gateway is out eth0 via 10.26.0.1. Can you provide the output of tracepath -n 8.8.8.8? –  mgorven Oct 24 '12 at 16:58
    
Updated with output. It doesn't end. I keep getting no reply –  balki Oct 24 '12 at 18:00
    
Your default route is definitely over the wired connection... Are you sure you can't get to the Internet? You are trying more than just a web browser, correct? Are there proxy settings in the browser's configuration? Operating system? Steps you've already taken to resolve the issue? –  Chris S Oct 24 '12 at 18:22
    
I am using ubuntu 12.10. Tried with both firefox and chrome. sometimes it opens. When I refresh, it goes away. With disabling wireless, it is always stable. No proxy settings configured anywhere. I tried ping google.com from terminal which doesn't work too. –  balki Oct 24 '12 at 20:46
    
ping works now again for some websites. Some services work, others dont. wget works fine. dropbox works. apt-get doesn't work, both browsers don't work. –  balki Oct 24 '12 at 21:00
show 2 more comments

migrated from serverfault.com Oct 24 '12 at 18:23

This question came from our site for professional system and network administrators.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.