Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Linux Mint 13 MATE 64-bit. Everything has been working for several weeks. Yesterday, when I tried to boot up my computer, after the BIOS screen flashes I reach a screen with a black background that reads at the top:

GNU GRUB version1.99-21ubuntu3.4

Then there is a box in which I can select from the following lines:

Linux Mint 13 MATE 64-bit, 3.2.0-31-generic (/dev/sdb2)

Linux Mint 13 MATE 64-bit, 3.2.0-31-generic (/dev/sdb2) -- recovery mode

Previous Linux versions

Memory test (memtest86+)

Memory test (memtest86+, serial console 115200)

At the bottom it reads:

Use the ↑ and ↓ keys to select which entry is highlighed. Press enter to boot the selected OS, 'e' to edit the commands before booting or 'c' for a command-line.

I have no idea why it started doing this and, worse, I have no idea how to get out of here. No matter which option I select, I can't get it to boot the OS. If I select either of the first two, it reboots to splash the BIOS and then I'm right back where I started. If I choose "Previous Linux versions" I get essentially the same screen with only two choices (which are the same as the first two choices listed above, Linux 13 MATE and the recovery mode). Again, choosing either one of those results in a reboot. If I try to run either of the memtest options, it reads:

error: unknown command 'linux16',

Press any key to continue...

Then it brings me back to the same screen

Can anyone help me please?

Hardware Specification:

  • Intel Core i5-2500;
  • ASUS P8Z68-V LX Intel Motherboard;
  • G. Skill Ripjaws series F3-12800CL9D-8GBRL (4GB x2);
  • Plextor 128GB M5S Series SSD

update:

If I press 'e' it reads as follows:

setparams 'Linux Mint 13 MATE 64-bit, 3.2.0-31-generic (/dev/sdb2)'
recordfail
gfxmode $linnux_gfx_mode
insmod part_gpt
insmod ext2
set root = '(hd1,gpt2)'
search --no-floppy --fs-uuid --set=root 249aaa9-029d-4599-b25d-92003c49e087    
linux /boot/vmlinuz-3.2.0-31-generic root=UUID=2492aaa9-029d-4599-b25d-92003c49e087 ro \quiet splash $vt_handoff 
initrd /boot/initrd.img-3.2.0-31-generic
share|improve this question

1 Answer 1

It sounds like your grub (the bootloader) config got messed up somehow. Try the following:

  1. Use your Mint CD to boot into a live system. Just as though you were going to install.

  2. Backup your existing configuration (just in case):

    cp /boot/grub/grub.cfg grub.cfg.old
    
  3. Open a terminal and mount your / (/dev/sdb2/ in your case) partition:

    mkdir tmp_root
    sudo mount /dev/sdb2 tmp_root
    
  4. Use chroot to set the newly mounted partition as your /:

    sudo chroot tmp_root
    
  5. Regenerate and reinstall the bootloader configuration:

    sudo grub-mkconfig > /boot/grub/grub.cfg
    sudo grub-install /dev/sda
    
  6. Reboot

share|improve this answer
    
When I try to boot from my USB (which I assume shouldn't be any different from a CD, right?) I again get that GRUB menu. Heading on top: "GNU GRUB version 1.99-21ubuntu3" followed by the options --Start Linux Mint --Start Linux Mint (compatibility mode) --Check the integrity of the medium When I select Start Linux Mint, the system again reboots. If I press 'e' to edit the commands before booting it reads: set params 'Start Linux Mint' set gfxpayload=keep linux /casper/mnlinuz file=/cdrom/pressed/mint.seed boot=casper quiet splash -- initrd /casper/initrd.lz –  Adam Oct 25 '12 at 2:23
    
@Adam, oookay. In that case, my answer is totally irrelevant. The screen you are describing is GRUB, a bootloader. That you see it is not a problem, that you cannot get out of it is. Don't really know what's going on but it does not sound like a linux oroblem as such, perhaps you should ask on superuser. Does it still happen if you have no external devices (usb drives or whatever) attached? –  terdon Oct 25 '12 at 21:58
    
Thanks. Yes, it does happen if I have no external devices attached. I unplugged everything but the essentials and still was having the same problem. Is it possible to just erase/format the partition that Mint was installed on from GRUB? Maybe if I do that I could just reinstall Linux. –  Adam Oct 29 '12 at 1:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.