Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This question already has an answer here:

My system is Linux 64bit, my hard-disk is a 1TB WD HD, connected to my computer by USB3.0. I found some files cannot be copied, they are video files, and it seems I can play the video. I ran e2fsck -fy /dev/sdb1 and no errors found. Then I read this article and tried the smartctl tool. But, I think it is because the HD is connected through USB, that the smartctl tools says the selftest function is not supported.

I used both drag-drop and rsync to try to copy the file, and both attempt results read error. I did not see more specific error message, or I do not know where to look at. :(

Now, I have no idea how to fix this disk error without format my disk, which I do not want.

share|improve this question

marked as duplicate by slm, Anthon, Zelda, jasonwryan, Renan Jan 17 at 20:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Cannot be copied by open them in editors, that's interesting –  warl0ck Oct 23 '12 at 13:52
    
it's video file. sorry I was not clear ;) –  davidshen84 Oct 23 '12 at 14:30
    
A video can be played partly even if some part is broken, depends on its encoding –  warl0ck Oct 23 '12 at 14:32
    
We don't know if you've got a disk error yet. Please post the error you get when you try and copy the files, including the command you use to copy them. –  EightBitTony Oct 23 '12 at 15:21
    
I checked my copy destination and my OS, and everything is fine. And each time I copy the file, I got a read error. –  davidshen84 Oct 24 '12 at 2:24

1 Answer 1

up vote 4 down vote accepted

Try adding -d sat, -d usbcypress, -d usbjmicron, -d usbsunplus to your smartctl command line, to use a transfer format that can pass through the USB-SATA bridge chip.

You can also try connecting it to a USB 2.0 hub / port, which may cause the bridge to behave differently in regards to ATA passthrough.

If none of those work, you can always just remove the hard drive from its external enclosure and connect it to your motherboard directly.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.