Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Is it possible to configure grub to have a dual boot setup behaving like described below?

  • When turning on PC and doing nothing, the default system should start as soon as possible without waiting for a countdown.
  • When wanting to boot another system, a key must be pressed to get to the normal grub menu to select a system.

Furthermore, I recently switched from grub legacy to grub and discovered that it takes notably longer to load before the menu shows up... Is it possible to reduce this time and get a fast boot?

My current /boot/grub/grub.cfg: grub.cfg

share|improve this question
    
Grub2 may be probing more hardware, or your system may be configured with some kind of timeout before the menu shows up. Please post your current grub.cfg. –  Gilles Oct 23 '12 at 22:09
add comment

3 Answers

just edit the grub defaults, type

sudo gedit /etc/default/grub

and then make sure that GRUB_HIDDEN_TIMEOUT_QUIET=false is replaced to GRUB_HIDDEN_TIMEOUT_QUIET=true. Also make sure that there is no # in front of it. Now close the file and type

sudo update-grub

which at least on Debian based systems is short for:

sudo grub-mkconfig -o /boot/grub/grub.cfg

And you should be done! Now if you want to boot a different operating system, simply hold SHIFT while booting.

share|improve this answer
    
What about GRUB_TIMEOUT and GRUB_HIDDEN_TIMEOUT? Note that you may have to use sth. like sudo grub-mkconfig -o /boot/grub/grub.cfg instead of update-grub. –  user905686 Oct 29 '12 at 17:12
add comment

To achieve this, you have to change the value of the GRUB_TIMEOUT value from 5 (default) to 0 .

1 - Setting the timeout to 0 will make GRUB wait nearly 0 sec and boot the default os automatically without counter down.

2 - if you want to boot another system then Holding down Shift while booting get to the normal grub menu to select a system.(if it does not work then set grub_timeout to 1 or 2 sec)

To change the GRUB_TIMEOUT value:

  1. su or sudo to the root account.

su -

  1. Open the GRUB.cfg file either in vi editor or gedit (Gedit is easy (GUI))

vi /boot/grub/grub.cfg

 or

gedit /boot/grub/grub.cfg

  1. Find GRUB_TIMEOUT and change it's value 0
  2. Save the changes
  3. Update grub

grub-mkconfig -o /boot/grub/grub.cfg

If you have any difficulty then watch my video on Youtube.

share|improve this answer
    
Sorry, read the question again: I mean the main system should start automatically without doing anything, not simply leave out the countdown. –  user905686 Feb 6 '13 at 11:16
    
sorry i edit the and now it might help you . –  Rahul Bhadana Feb 6 '13 at 13:04
add comment

Yes, grub1.9X is much slower than grub0.9X, I want to know how to speed that up as well.

And your first request, you could just reduce the timeout (i.e set timeout=5) to 1 second, when you need to boot another system, just kept pressing the arrow keys (up / down / left), grub would stop the counter.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.