Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am Trying to configure ProFTPd to change group for newly created files/directories.

In my config I have this:

<Directory /home/*>
  GroupOwner www
</Directory>

Which does not seem to work.

All users are added to www group.
Debug shows nothing regarding to a group change.

I'm using FREEBSD 9.0-release.

EDIT: I'm willing to try any other FTP server that makes this easier.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

After a deep research, I found out that proftpd is not capable of changing a group of newly uploaded file..

However workaround was found:

You need to simply change group for the user's home folder, after which all newly uploaded files will inherit the group from the home folder.

Not much of a solution, but at least something. =)

share|improve this answer
add comment

In vsftpd you can do this with the local_umask=<number> option. This changes the permissions of an uploaded file for local users. With this option you can thus make sure that group member always have read and write permissions on files and directories.

You need to check the default file permissions (and owner and group, just to be sure!) of uploads and then calculate the correct umask. The default umask that vsftpd uses is 077. Hope this helps!

share|improve this answer
    
chmod is not related to this, i need chown –  Radio Oct 23 '12 at 18:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.