Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For a custom installation, I need to add a few rpms from the SDK dvd that comes with the main SLES dvd, onto the main SLES installation dvd. This is because my superiors want 1 single dvd to install SLES from, without the need of extra dvds or ftp-repositories.

As such, I've been trying to accomplish just that.

What I've done is

  • extracted the files from the dvds for both the main installation and the SDK
  • copied the 3 rpms in question from the SDK to the main installation (/suse/x86_64/)
  • added the rpms to packages.*.gz (/suse/setup/descr/packages.*.gz)
  • re-calculated the SHA1 sum for the packages.*.gz and entered them in content (/content)

After this, I recreated an ISO image from this modified image.

However, when testing the ISO on a virtual machine, the installation gave me an error saying: cd:/ Invalid signature Installation aborted.

In order to fix this, I added insecure=1 to isolinux.cfg (/boot/x86_64/loader/isolinux.cfg).

This worked, but now I get another error, see the screenshot below.

Installation signature verification failed

Any suggestions on how to solve this? I've seen people mention adding a custom gpg-key to the initrd, but that is generally for an add-on product. I'm unsure of what to do next with this. :/

I've added the following to my autoyast xml file:

  <post-scripts config:type="list">
      rpm -i extra/*.rpm > /tmp/extra.log

As such, I've added my extra rpm's in a folder called extra in my ISO. However, now the installation just fails:

Installation general failure

As per Nils' suggestion, I've added the rpm's to a separate folder on the ISO and install them via the post-script section in an AutoYast profile. The issue I reported with the script above was the result of the <script><source>...</source></script> elements missing around the CDATA. Adding the part below fixed my problems.

  <post-scripts config:type="list">
          mount /dev/dvd /mnt;
          cd /mnt/extra;
          rpm -i <rpms>;
          umount /mnt;
share|improve this question
up vote 1 down vote accepted

Put the rpms into any place you like on the DVD and use a autoyast-post-install-script to install these rpms.

Apart from that I do not see the sense in that request. That system has to be patched after the installation. So this means repositories contacted via network - so the rpms could even be on the network...

share|improve this answer
The sense lies in the fact that the DVD can be used by people without the proper knowledge about external repositories. An Install SLES for our product for dummies. :P – ThaMe90 Oct 23 '12 at 6:30
I've tried your suggestion, see my updated question. :/ – ThaMe90 Oct 23 '12 at 8:05
@ThaMe90 You could have generated that xml-snippet via yast2: Automated installation. – Nils Oct 23 '12 at 20:34
Huh, I never knew that. :O – ThaMe90 Oct 24 '12 at 6:51

Granted this is for RHEL, this may help you see what else you need to do: http://www.harkness.co.uk/other/RHEL4_custom_dvd.html

share|improve this answer
Nice information, but the whole filesystem on the dvd/ISO is different per OS. – ThaMe90 Oct 22 '12 at 14:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.