Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed Slackware 14.0. I installed vmware player using this command:

sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

Which I found from this website:

http://www.linuxquestions.org/questions/slackware-14/installation-of-vmware-player-4-on-slackware-13-37-32-bit-909539/

That allowed me to install a guest version of Windows XP (microcontroller programming). But I'm unable to connect a usb device to the guest xp vm. The usb device is acting like a serial device.

Any thoughts?

share|improve this question
    
I forgot to mention, this is the error I'm getting when I try to connect the USB device to the guest xp vm: serial1: Unable to open the "COM1" serial port: No such file or directory. –  user26138 Oct 22 '12 at 2:28
    
You can always edit your question, so I suggest you move the content of your comment into the question itself. –  EightBitTony Oct 22 '12 at 7:19
add comment

2 Answers

Power down your VM and exit VMWare player. Locate the .vmx file of this virtual machine. Open it with text editor and seek for the serial0.fileName parameter.

change its value to "/dev/ttyUSB0" (use the actual name if you have more than one USB serial device connected to you host system; they are all named with ttyUSBxxx, where xxx - is a numeric):

serial0.fileName = "/dev/ttyUSB0"

Save the file and start your VM. It should find the port now.

share|improve this answer
add comment

I saw this same error using a VM of Debian on Windows with VMPlayer when trying to bring in a real serial port. Everything was set properly as Serge said in his answer, it just happened that my serial port was open with another application.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.