Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

While playing Nexuiz on my Ubuntu in fullscreen mode the volume control buttons on my laptop don't work at all, externally after minimizing the game increasing/decreasing the sound solves the problem but there is no in-game vol control?

Also when on headphones the game music plays on the laptop speakers as well as on the headphones!

What could the problem be? Is this a sound driver issue or x-org issue? its also happening with someone i know while playing Warzone2100 on Ubuntu 12.04.

share|improve this question
add comment

1 Answer

It works if you use acpid to listen for your XF86 volume key events, and use amixer to set the volume manually, but you need to disable the original volume key listener to prevent "double volume change"

As I only know about how this could work with xfce4-volumed, here I will only provide the ACPID handler script:

#!/bin/sh
# Default acpi script that takes an entry for all actions

set $*

case "$1" in
    button/volumeup)
        amixer sset Master 3+ # increase volume by 3%
        ;;
    button/volumedown)
        amixer sset Master 3- # decrease volume by 3%
        ;;
esac

You will need to find these part in your acpid script and put the axmier lines in.

Read this link for details

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.