Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I found myself always holding Shift when I delete a file with Thunar (the XFCE file manager).

When I was using Windows I was always disabling "recycle bin" immediately after installation. I've looked for similar option in Thunar settings but had no luck finding it.

Do you happen to know a way?

share|improve this question
2  
Since I assume that XFCE conforms to the FreeDesktop.org Trash Specification, a workaround would be to run a cron job every minute calling trash-empty (from the package trash-cli). –  Marco Oct 14 '12 at 18:23
    
Looks like an ugly "crutch" of a kind for me on first sight but may be a nice compromise at the same time: at least I will be able to restore a file during some time after deletion if I realize I've done it by a mistake (happened to me about 5 times during 20 years - had to use special undeletion utilities to restore). –  Ivan Oct 14 '12 at 18:27
1  
It definitely is! If you want finer control of what is deleted and when, I would suggest having a look at the package autotrash. Calling it from a user crontab I would consider a clean solution. It however does not answer your question, that's why I leave it as a comment. –  Marco Oct 14 '12 at 18:34
add comment

1 Answer

According to the Xfce FAQ, you cannot disable the Trash.

They provide three suggestions, two of which which are also mentioned in the comments above:

  1. Use Shift + del to bypass the trash bin and immediately delete something for real.

  2. use cron to clean the trash every now and then.

  3. or create custom action for permanent delete(like in gnome) with action: rm %f then in context menu you'll have button “permanent delete”

Personally, I use the a cron job that runs every 24 hours that calls trash-empty. You can simply call the command by itself, or give an option(in days) to remove files that have been in the trash longer than that specified number of days.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.