Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I want to play this java simulation: in java 3d mode on a linux (ubuntu) system. But it doesn't work.

If I switch to java 3d-mode it complains that java 3d is not installed. sudo aptitude install libjava3d-java didn't help.

Then I did a right click in this java app and selected Diagnostics-> About Java 3D. Then I get the message:

Java 3D was not found in: /usr/lib/jvm/java-6-openjdk-i386/jre/lib/ext:/usr/java/packages/lib/ext

Then I tried

cp /usr/share/java/*3d* \

but I get the same error message again.

I start the java app like this:

java -jar ejs_astronomy_SolarLunarEclipse.jar

I tried this on two systems, one freshly installed and also switched from openjdk to sun-jdk temporarily without any effect.

Any idea how I can get this work?

share|improve this question

1 Answer 1

Java 3D is not included in the JRE or JDK.

Some instructions for installing on Ubuntu are here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.