Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I run yum update, I receive the following error:

[root@chandru chandru.math]# yum update
Loaded plugins: presto, refresh-packagekit, remove-with-leaves
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: kdebase-runtime-libs(x86-32) = 4.5.3-3.fc13 for package: kdebase-runtime-4.5.3-3.fc13.i686
---> Package kdebase-runtime-libs.i686 0:4.5.4-1.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: kdebase-runtime-4.5.3-3.fc13.i686 (@updates)
           Requires: kdebase-runtime-libs(x86-32) = 4.5.3-3.fc13
           Removing: kdebase-runtime-libs-4.5.3-3.fc13.i686 (@updates)
               kdebase-runtime-libs(x86-32) = 4.5.3-3.fc13
           Updated By: kdebase-runtime-libs-4.5.4-1.fc13.i686 (updates)
               kdebase-runtime-libs(x86-32) = 4.5.4-1.fc13
           Available: kdebase-runtime-libs-4.4.2-3.fc13.i686 (fedora)
               kdebase-runtime-libs(x86-32) = 4.4.2-3.fc13
 You could try using --skip-broken to work around the problem
** Found 6 pre-existing rpmdb problem(s), 'yum check' output follows:
kdebase-runtime-4.5.4-1.fc13.i686 is a duplicate with kdebase-runtime-4.5.3-3.fc13.i686
kdebase-runtime-4.5.4-1.fc13.i686 has missing requires of kdebase-runtime-libs(x86-32) = ('0', '4.5.4', '1.fc13')
kdebase-runtime-flags-4.5.4-1.fc13.noarch is a duplicate with kdebase-runtime-flags-4.5.3-3.fc13.noarch
6:kdelibs-4.5.4-2.fc13.i686 is a duplicate with 6:kdelibs-4.5.3-3.fc13.i686
6:kdelibs-common-4.5.4-2.fc13.i686 is a duplicate with 6:kdelibs-common-4.5.3-3.fc13.i686
phonon-4.4.3-2.fc13.i686 is a duplicate with phonon-4.4.2-1.fc13.i686

Please let me know what to do.

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

I'm not a regular Fedora user but the following is a generic solution I've used in the past.

Try running

$ yum clean all

and then rerunning the yum update command.

share|improve this answer
    
Worked for me on Centos 6.2 with "UnicodeDecodeError". Thx –  Deele Dec 28 '11 at 6:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.