Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install Linux alongside Windows 8 on my new Asus Zenbook UX32VD, which has both an Intel HD 4000 and a NVidia 620M

I've been having quite a few problems booting up linux via USB so I can install it. So far, I've tried Linux Mint Debian edition, Crunchbang, Debian, and Ubuntu.

What usually happens is that after the initial loading, I see the mouse cursor for a couple of seconds, and then the screen goes black, for good. The rest of the system seems to keep going, but I have no image whatsoever, and have to shutdown the hard way.

However, in some of my attempts with Ubuntu and Mint, I managed to boot. What changed those times? I have no clue. In one of those attempts, I finished the instalation of Mint, but after rebooting to the installed system, the same problem occurred

I also tried adding boot options, particularly nomodeset, and i915.modeset=1 driver=intel. The first time I tried each of them, Mint booted correctly, making me think it was the solution. But later attempts resulted in the same black screen

But with Debian, it seems everything goes well, and I managed to install it. But I'm currently having some problems configuring the system, particularly the Fn keys (any tips on that?)

So, my question is, how should I proceed in order to boot correctly, knowing that this is probably some kind of problem with detecting the graphics card? I realize that newer laptops are very likely to have problems like these, but if there's a solution for it already, I couldn't find it anywhere.

share|improve this question
1  
There is no real question. –  drahnr Oct 15 '12 at 21:19
2  
I think the question is pretty much obvious, even though i didn't ask it explicitly. but i'll edit it since you asked –  Naps62 Oct 16 '12 at 0:24
    
When you boot normally and get the blank screen, can you see (in some strong light or smth) the desktop? (It would mean that display backlight is off). –  UldisK Mar 15 '13 at 9:47
add comment

1 Answer

Try to install ubuntu minimal and not install desktop environment. When your install finished, login to console and then install xorg, latest drivers from here and your desirable DE. Then, run startx and see what happens.

share|improve this answer
    
I did as you suggested. First of all, i had to install the Xubuntu packages from the Ubuntu minimal setup, otherwise i could not get any internet connection (both Wifi, and usb-to-ethernet, which is my laptop has available) After installing, i got the same black screen, but was now able to use nomodeset to get a root console. However, trying to install the nvidia drivers or bumblebee from there, resulted once again in a black screen. Only now, even nomodeset works, so i got to a dead end –  Naps62 Nov 5 '12 at 3:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.