Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Any advice as to how to debug this:

My K800 USB Wireless Keyboard's repeat rate intermittently stops working. It will start behaving erratically and when holding a key down it will either not repeat at all, or only repeat 3-4 times.

This occurs from any X11 (using xmonad), including konsole or gnome-terminal, etc. If i switch to a pseudo/virtual terminal ( C-Alt-F2 etc. ) , then the repeat rate is fine.

I have tried xset r rate 350 30 and it doesn't work.

I have left it overnight and come back the next day to find that, magically, it all of a sudden works correctly.

Then randomly, at some point in the future, it will start again. And randomly it will stop later on.

I don't even know how to start to investigate this problem. I suspected maybe it is udev related? I tried something like this, as a gamble:

sudo rm -rf /dev/usb/*
sudo rm -rf /dev/bus/usb/*
sudo udevadm trigger

and it didn't help.

Also - when selecting text with the mouse in konsole ( but not firefox ),
the same stutter/stop occurs when the problem is happening. I can select maybe 1 or 2 lines and then it stops selecting ( despite still having the mouse button pressed down )

uname: Linux 3.5.6-1-ARCH #1 SMP PREEMPT Sun Oct 7 19:30:49 CEST 2012 x86_64 GNU/Linux

share|improve this question
    
Perhaps low battery? BTW, if you find out, please answer your own question for future reference. –  vonbrand Jan 24 '13 at 19:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.