Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After a recent upgrade on Kubuntu, Kate editor (v3.8.5) shows odd lines under the entire text of previously created simple text files. New files usually have only the first line underlined. Maybe if I knew what this is called, I'd be able to find something. It does the same in KWrite, so it could be something in whatever the two have in common. Highlighting is set to "None'. Here's what it looks like:

EDIT: Thanks, but that command doesn't seem to have any effect on this. This is KDE 4.8.5. In another example, the lines change a bit:

Another example

share|improve this question
    
I see a small picture of line with no context (eg can't even tell it's a screenshot of kate). –  jordanm Oct 11 '12 at 4:14
    
@question: Your screen shot is not very clear –  The Dark Knight Oct 11 '12 at 5:43
    
@question: Which version of KDE are you using ? –  The Dark Knight Oct 11 '12 at 6:00
    
@question: Then i will suggest you to upgrade your KDE to 4.9, which seems to have a way of turning off the line modification markers. –  The Dark Knight Oct 12 '12 at 10:02
add comment

1 Answer 1

I think what you are referring to here is a functionality called : Line Modification Indicator and you want to disable it.

If so, then this is the info :

  1. On KDE 4.8.0, there is no way to disable the line modification markers.

  2. In KDE >= 4.8.1, you can disable them by first closing Kate and then typing :

    kwriteconfig --file katerc --group "Kate View Defaults" --key "Line Modification" --type bool false
    

    To enable it again, close Kate and run:

    kwriteconfig --file katerc --group "Kate View Defaults" --key "Line Modification" --type bool true
    

    However, this only affects Kate; not KWrite, Kile, KDevelop or any other application using Kate Part. If you want to disable the markers for KWrite, Kile or KDevelop, use kwriterc, kilerc or kdeveloprc instead of katerc.

  3. In KDE >= 4.9, there is a graphical option in the editor configuration dialog in “Appearance > Borders > [x] Show line modification markers”.

To know more about it use this link.

Hope this helps you .

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.