Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Xubuntu 12.04 in a remote environment. Off late, I am observing that sometimes the cursor turns into a hand and stops responding. I cannot do anything to fix it.

The only solution seems to be to terminate the XFCE session and re-login.

I am observing this when using a remote connection. Anyone seen this or know a solution or workaround ? I am just frustrated with this problem coming up every so often.

------------- EDIT ----------------

The LD_PRELOAD method doesnt seem to work for me. Is there a command line way to generate AllowDeactivateHold ?

------------- EDIT ----------------

Can we use xinput to create the effect of AllowDeactivateHold ?

share|improve this question
add comment

2 Answers

I think here you will have to get your hands dirty. I had previously hard about XFCE debugging which naturally tells you about why what is happening and how. But , i do not know much about that. So you can google it or you can use this link: http://spurint.org/projects/xfce4-debugging/

This link is quite good and it gives a very good idea about how to debug by using a how-to-do-it approach.

"Debugging crashing Xfce apps isn’t terribly difficult, and can be a big help to Xfce developers when they’re trying to fix bugs. If the problem you’re having is a crash of a particular application, usually you’ll want to get what’s called a ‘backtrace’ or ‘stack trace’ using a debugger, such as gdb."

share|improve this answer
    
I dont know if I can classify this as a crash. The mouse pointer moves around. The cursor turns into a hand and things are unclickable. Although, on the remote server, I am able to login using putty and access and kill applications. Although to get everything back to work I have to kill xfce4-session. Thanks for the link. I will try to find out more. –  boffin Oct 10 '12 at 16:00
    
@boffin: Welcome –  The Dark Knight Oct 10 '12 at 17:07
add comment

There might be an application that grabbed the pointer but failed to release the grab. One thing you can do is configure your local Xserver to allow grabs to be manually deactivated by adding this to your ServerOptions section:

Option "AllowDeactivateGrabs" "true"

and then press Ctrl-Alt-Keypad-/ to break the grab. However, note that this particular option has been in flux lately (see this bug report).

share|improve this answer
    
This is a very convincing answer. Thanks for your attention. Do I add this entry in xorg.conf ? Is there another place I can do this... I am not a superuser on the machine. –  boffin Oct 10 '12 at 19:34
    
Yeah, it's in xorg.conf. If you're not a superuser, you could just give the key combination a try to see if it's enabled (it used to be enabled by default). Another alternative, if you can figure out which program is doing these grabs, would be to use the LD_PRELOAD workaround shown in comments 4 and 5 of the bug report I linked. That essentially makes those functions no-ops so that the program simply can't do the grabs in the first place. Of course, this would first require that you find out what program is doing the grabs, which may be difficult. –  Jim Paris Oct 10 '12 at 19:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.