I need to install a GEOS version >= 3.2.2, and doing so is beyond my current aptitude (pun intended).
The current Debian squeeze version is 3.2.0, which will not work for my purposes (using the
rgeos package in R).
I've tried the following:
- Installing the 3.3.3 package from the Debian wheezy repository via
- Installing several 3.2.2 packages from the Ubuntu repository.
All fail because I need
libstdc++6 (>=4.6) and I have version 4.4.5-8.
I assume that what I need is to install a newer libstdc++6, but I want to do so in a way that doesn't break existing packages. Is it possible to have two versions installed at once, with the newer one being used only for GEOS? And if so, how do I do that.
As per @Marco's suggestion, I've compiled GEOS and it compiles/installs properly but with both 3.3.3 and 3.2.3 I get the following error when I try installing the
rgeos package in R:
* installing *source* package ‘rgeos’ ... ** package ‘rgeos’ successfully unpacked and MD5 sums checked checking geos-config usability... yes configure: geos-config: geos-config configure: GEOS version: 3.2.3 checking geos version over 3.2.1... yes checking geos-config clibs... no checking for gcc... gcc -std=gnu99 checking for C compiler default output file name... a.out checking whether the C compiler works... configure: error: cannot run C compiled programs. If you meant to cross compile, use `--host'.