Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Ok so i want to view the ram and have it run continuously

     root@another:/etc/mysql/database_backups# free -mt
                 total       used       free     shared    buffers     cached
    Mem:           998        870        127          0         92        362
    -/+ buffers/cache:        415        582
    Swap:         2047         31       2016
    Total:        3046        902       2144

    root@another:/etc/mysql/database_backups# free -mts
    free: option requires an argument -- 's'
    usage: free [-b|-k|-m|-g] [-l] [-o] [-t] [-s delay] [-c count] [-V]
      -b,-k,-m,-g show output in bytes, KB, MB, or GB
      -l show detailed low and high memory statistics
      -o use old format (no -/+buffers/cache line)
      -t display total for RAM + swap
      -s update every [delay] seconds
      -c update [count] times
      -V display version information and exit

the first command works great but adding the s flag gives me an error but i can clearly see that is an available flag....any ideas on what i am doing wrong and if there is a better way of doing this

share|improve this question

migrated from serverfault.com Oct 5 '12 at 10:03

This question came from our site for system and network administrators.

5  
See [-s delay]? That delay word cannot be omitted when using -s. –  Lekensteyn Feb 6 '12 at 17:30
4  
Facepalm in 3...2...1... –  Magellan Feb 6 '12 at 19:14

1 Answer 1

Try the following.. You don't have an argument for how often to do the update.

free -mt -s 3
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.