Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am very new to UNIX, learning groff with the help of cygwin on Windows XP SP3.

I have downloaded groff-binaries from here, but using cygwin, I could not able to re-produce ps files.

I have used following command in cygwin:

$ groff grnexmpl.me > grnexmpl.ps

But, in generated grnexmpl.ps file, all special formatting are gone. When I look inside the grnexmpl.ps.gz archive(comes with the binaries) and the grnexmpl.ps looks beautiful. It would be a great help if somebody assist me to understand what is going here? Am I missing something?

share|improve this question
up vote 4 down vote accepted

You need to tell groff which macros you want to use. In this case, you want

groff -ge -me -mwww grnexmpl.me > out.ps

If you want to see the picture of the circuit diagram, you'll also need grnexample.g present in the directory.

I found this by running grog to guess the macros, and then added the www macro, since I could see there was HTML in the source document.

share|improve this answer
Thank you very much, for your prompt reply. The issue is solved now. The command works like charm. But, as you refers to grog, I just unable to run that. I could see the file to be present at /usr/bin/grog and I also have strawberry perl installed in my mc. But running command grog -Tdvi grnexmpl.me cygwin trows error «Can't open perl script "grog": No such file or directory». Could you please tell me, why? – Cylian Oct 5 '12 at 4:46
I guess using cygwin build perl would be the solution to run perl scripts from cygwin! – Cylian Oct 5 '12 at 7:05
@Cylian - Sorry, I don't use Cygwin. But it may be a path issue with the wrong Perl install: What is the reason for this “Can't open perl script : No such file or directory?” – ire_and_curses Oct 5 '12 at 7:44
Thank you the issue is solved now. – Cylian Oct 5 '12 at 16:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.