Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a little trouble getting trac 1.0 installed via easy_install:

[box]# easy_install Trac==1.0

Downloading http://pypi.python.org/packages/source/T/Trac/Trac-1.0.zip#md5=3dd2e883179879c8fa5b98c984f15058
Processing Trac-1.0.zip
Writing /tmp/easy_install-FOeJcG/Trac-1.0/setup.cfg
Running Trac-1.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-FOeJcG/Trac-1.0/egg-dist-tmp-b2610A
Trac requires Python 2.5 or later
error: Setup script exited with 1

Python 2.6 is also installed on my system ( /usr/bin/python26, /usr/include/python2.6/, /usr/lib/python2.6/, /usr/lib64/python2.6/, ect ).

Could I pass one of these as a prefix for easy_install? If so, which am I looking to include - the libs or the include path?

EDIT Using this answer in SO, I tried making a symlink to python/python26. Continue to get the same error as above.

share|improve this question

migrated from stackoverflow.com Oct 4 '12 at 15:10

This question came from our site for professional and enthusiast programmers.

If you have python26 you probably need to install setuptools26 which has a binary called easy_install26 which specifically works with python 2.6. – Sean C. Oct 4 '12 at 22:54
I'll give that a try tomorrow. – a coder Oct 5 '12 at 3:13
Ok got it now. I executed: sh ./setuptools-0.6c11-py2.6.egg and now have a working easy_install-2.6. Now to back up the sqlite database & see if I can get Trac 1.0 installed. – a coder Oct 5 '12 at 17:23
Tried upgrading .12 to 1.0 per documentation. Got no errors, looked fine, but after reloading httpd, I'm still seeing trac .12. – a coder Oct 5 '12 at 17:30
Blew out Trac .12, installed Trac 1.0 with easy_install-2.6 - it's up and running now. If you'll put your comment as answer I'll be glad to give you some mojo. – a coder Oct 5 '12 at 18:25
up vote 1 down vote accepted

The issue presented here is one which occurs when you use a distribution that has both Python2 and Python3 enabled in its repositories. To resolve conflicts, the earlier versions have had their version numbers appended to the binary.

In the case with this question, a proper version of setuptools for Python v2.6 had to be installed to provide the easy_install-2.6 binary.

Glad you got it solved!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.