Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed slackware 14 on my acer aspire one za3. I cannot start the X server. Here the output of command startx

xauth:  file /home/emanuele/.serverauth.1984 does not exist
X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.0 Slackware Linux Project
Current Operating System: Linux darkstar 3.2.29-smp #2 SMP Mon Sep 17 13:16:43 CDT 2012 i686
Kernel command line: BOOT_IMAGE=Linux ro root=803 vt.default_utf8=0
Build Date: 23 August 2012  02:27:55PM

Current version of pixman: 0.26.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  3 18:46:58 2012
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
vesa: Ignoring device with a bound kernel driver

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
 at http://wiki.x.org
for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Seem to me that the psb module is loaded. Here the output of lsmod|grep psb

psb_gfx               180538  0 
drm_kms_helper         22825  1 psb_gfx
drm                   151850  2 drm_kms_helper,psb_gfx
i2c_algo_bit            4543  1 psb_gfx
i2c_core               16454  6 i2c_algo_bit,i2c_isch,drm,drm_kms_helper,videodev,psb_gfx
video                   9938  2 poulsbo,psb_gfx

And this is the output lspci of my vga card

00:02.0 VGA compatible controller [0300]: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller [8086:8108] (rev 07) (prog-if 00 [VGA controller])
Subsystem: Acer Incorporated [ALI] Device [1025:0244]
Flags: bus master, fast devsel, latency 0, IRQ 7
Memory at b0080000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 1800 [size=8]
Memory at c0000000 (32-bit, non-prefetchable) [size=256M]
Memory at b0000000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at <unassigned> [disabled]
Capabilities: [d0] Power Management version 2

I don't understand why it does not work. Where is the problem?

Edit: after a rmmod poulsbo psb_gfx, X start (with vesa driver i suppose). May be a bug?

share|improve this question
add comment

1 Answer

You should hand-edit the "Screen" section in your xorg.conf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.