Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to create a multi-distro mutli-boot dvd image containing (amongst others) the SystemRescueCD iso. I'm using GRUB as the boot loader and I've managed to get most of the other ISOs booting fine (testing in VirtualBox before I burn to disc). But the RescueCD iso fails to boot fully and just drops me out to a mini console.

It starts to load the kernel image and initram.igz okay, then after it prompts for the keymap it attempts to locate the sysrcd.dat file (which contains the file system image) by trying to mount /dev/sr0 and /dev/sd0 but this is the wrong place. I need it to mount /dev/scd0 -- the .dat file is located in /distro/systemrescuecd on the CD image.

Does anyone please know what file I need to edit to correct the mount paths and/or what command(s) I can append to the kernel load string in GRUB to point it at the right folder/mount point?

Thanks

share|improve this question
1  
From the manual, you might try the 'isoloop=XX.iso' as a temp fix. –  warl0ck Oct 3 '12 at 11:28
    
Hey warl0ck thanks, I had seen that in the SRCD documentation. I tried it earlier but it didn't work for me, just tried it again though and it worked fine! I must have missed something before (I blame bleary eyed frustration). Guess there wasn't any need for me to unpack the ISOs after all! Oh well, at least it works now. Thanks dude –  Chris Oct 3 '12 at 14:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.