Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a system to install SLES 11 on, via a serial console. As this procedure is likely to be executed across multiple systems, I want to automate the whole process. As such, I first did a manual installation and created an autoyast profile of the installed system. Next, I added the autoyast profile to the installation DVD and edited isolinux.cfg to offer the option of autoyast.

When I try out the DVD in a virtual machine (see screenshots below), I get a graphical boot loader that displays my autoyast option perfectly fine.

Graphical install

But when I switch to the textual boot loader, the option isn't there anymore.

Textual install

Instead, if I wish to use the autoyast profile for the installation, I need to specify the autoyast=file:///<path-to-file> kernel option to make it work.

My question thus revolves around this: does the textual boot loader use the same configuration file for the menu? Or do I have to edit another file on the DVD.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

So it seemed like I needed to edit another file besides isolinux.cfg. The bootloader for the textual installation does not generate it's text based on what is written in isolinux.cfg. Instead, it just displays the text from a file called message in the same directory as the isolinux.cfg file is in.

Furthermore, the textual boot loader does use the isolinux.cfg, i.e. when presented with the textual boot loader, one can simply enter autoyast (if configured) and it would still run the automatic installation.

So, by adding the autoyast line of text to the message file, I was able to see the option in the textual installer.

share|improve this answer

I was typing the autoyast kernel parameters and then noticed the bottom of your post. You may just need to edit your grub options on the DVD to include the autoyast= parameter.

share|improve this answer
    
Which file would that be? I can't seem to locate any grub related files on the DVD. :/ –  ThaMe90 Oct 3 '12 at 14:05
    
It may not be grub. Do you have a /boot/loader directory on the DVD? –  Josh Blair Oct 3 '12 at 14:11
    
Yes, /boot/x86_64/loader/, in which I can only find isolinux.cfg, and to which I already added the autoyast information. I have also found gfxboot.cfg, but this seems to be for the display for the graphical boot loader. –  ThaMe90 Oct 3 '12 at 14:15
    
What does your entry look like? Anything like this: # autoyast label Autoinstallation kernel linux append initrd=initrd splash=silent showopts instmode=cd autoyast=default Sorry -- 1, my network is being weird and 2, I cannot figure out how to get the line breaks to stick in the code section. –  Josh Blair Oct 3 '12 at 14:41
    
# autoyast label autoyast kernel linux append initrd=initrd autoyast=file:///boot/autoinst.xml console=ttyS0,115200 splash=silent showopts –  ThaMe90 Oct 3 '12 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.