Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am installing imagick-v3.1.0RC2 package on CentOS 5.5. I have ImageMagick 6.7.9-9 installed as well and have a problem on the make step.

Problem is that its cannot find included file:

/usr/local/include/ImageMagick/wand/magick/accelerate.h:25:31: error: magick/morphology.h: No such file or directory

If I copy folder magick over into /usr/local/include/ImageMagick/wand/magick/magick then it will find it but will say some other file is missing in magic/xxx.h so I have to copy magick again and again there should be some way around?

I created a symlink in /ImageMagick/wand/magick ln -s ../magick magick however it still has the same problem inside file accelerate.h on line 25 it has #include <magick/random_.h>

I also tried to do

make --include-dir=/usr/local/include/ImageMagick/ --include-dir=/usr/local/include/ImageMagick` and `make -I /usr/local/include/ImageMagick/ -I /usr/local/include/ImageMagick

I ended up running make -n to show all commands that make will execute and then added -I /usr/local/include/ImageMagick/ -I /usr/local/include/ImageMagick to them and run one by one manually.

Isn't there faster way?


tick was to find where file is with find / --name "missing.file" and then add the symlinks in the folder where i run Make i.e. /usr/src/imagick-v3.1.0RC2/

ln -s usr/local/include/ImageMagick/magick magick


ln -s usr/local/include/ImageMagick/wand wand
share|improve this question
add comment

1 Answer

try adding -I until the wand directory like -I/usr/local/include/ImageMagick/wand or -I/usr/local/include/ImageMagick/wand/magick

share|improve this answer
its the same error –  John Smith Oct 2 '12 at 22:12
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.