Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to compile and install X.org (for a single card/multiseat in this tutorial) by getting source from here and installing it by:

./configure --enable-kdrive --enable-xephyr --enable-xfake --enable-xfbdev --enable-kdrive-kbd --enable-kdrive-mouse --enable-kdrive-evdev --enable-glx-tls
sudo make install

after this Ubuntu freezes in boot on the Ubuntu logo and doesn't boot up!
Note: it boots in recovery mode and X starts by using startx from terminal (in recovery mode) ; it just doesn't start normally!
I'm using Ubuntu 12.04

What is the problem?
How can I fix it?

share|improve this question
could you upload the X.log and dmesg logs? It sounds as if the hardware discovery doesn't work – Hartmut Oct 2 '12 at 8:59
@Hartmut: currently i checked boot output; lightdm fails! – RYN Oct 2 '12 at 12:27
up vote 2 down vote accepted

Have you generated an xorg.conf file? Try booting into recovery mode, and running this command:

$ Xorg -configure

That will create an xorg.conf file at /root/xorg.conf.new. Edit the file as needed and copy it to /etc/xorg.conf. Reboot and see if it works.

If that doesn't work, try generating an xorg.conf file using nvidia-xconfig. You will also probably need to reconfigure the driver. try the following:

sudo apt-get install module-assistant nvidia-kernel-common nvidia-kernel-dkms nvidia-settings nvidia-xconfig
sudo m-a auto-install nvidia-kernel${VERSION}-source
sudo nvidia-xconfig
share|improve this answer
it gives Missing output drivers. Configuration failed !! – RYN Oct 2 '12 at 12:19
Excellent! Edit your Device section to give the right drivers ('radeon' for ATI, 'nouveau' for nvidia). Also install them if necessary. See the Arch Wiki [wiki.archlinux.org/index.php/Xorg](here) for more information. – terdon Oct 2 '12 at 12:34
But there is no xorg.conf to edit! Xorg -configure gives this error! – RYN Oct 2 '12 at 12:42
Ah, have you installed the drivers for your card? What is your card? – terdon Oct 2 '12 at 12:56
before compiling Xorg , yes (on previous X) ; it is nVidia 210 – RYN Oct 2 '12 at 13:20

Try to press "End" wile showing the logo to see where it stops so we can have a better idea on what to do next, but xorg.log might tell you something too.

share|improve this answer
It fastly shows outputs and clears screen then it prompt for username (TTY terminal login) – RYN Oct 2 '12 at 9:52
Terminal login? Hum, seems that X is not starting at all, but I guess you could check that with ps or top. Are you sure you've setup "/usr/bin/startup-X':" script (described in the tutorial correctly)? – Mikec Oct 2 '12 at 10:02
currently i checked boot output; lightdm fails! – RYN Oct 2 '12 at 12:29
you could try to do a sudo apt-get update and reinstall lightdm after that. Or maybe even instal gdm and see if you can get the login screen. – Mikec Oct 3 '12 at 10:27
.... But the xorg.log must mention something more... Make sure you have the latest graphic drivers, and check if for instance you have an intel, but nvidia grapichs are instaled, I had problems with lightgm once because of that... – Mikec Oct 3 '12 at 10:34

Ubuntu 10.04 used to refuse to boot X, when xorg.conf was present (it was left from 9.10). I removed it and it booted ok.

share|improve this answer
tried but no effect! – RYN Oct 2 '12 at 12:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.