Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

What I need to do is to connect preconfigured OpenWRT router to another network through WAN cable connection.

My router assign the IP address to new router but even if I use this address it still rejects my SSL connection (as it appears).

I've done some googling and read some OpenWRT wiki pages but then I found out that I am missing directories such as '/etc/config'.

Any suggestions?

share|improve this question
    
I'm confused, its preconfigured as in someone else set it up for you? In which case, didn't they tell you? (I've done this for people with Linux boxes, and I give them instructions—preferably simple, like "plug the ethernet cable in here.") Or do you mean it came with OpenWRT pre-installed (but not configured)? –  derobert Oct 2 '12 at 6:14
    
@derpbert, I got this router from school to practice few things. I know how to connect it through cable to PC but when I tried to plugin cable from my home router LANs to OpenWRT WAN jack it won't let me connect. It gets my homes local IP address but is still unaccessible. Why? –  HelpNeeder Oct 2 '12 at 6:21
    
It was pre-installed and pre-configured I suppose, but not working :( –  HelpNeeder Oct 2 '12 at 6:22
3  
Well, it sounds like when you connect it to the PC, you're accessing it from its LAN ports, but when you connect it to your home network, you're trying to access it from its WAN port. Maybe administration via WAN is disabled/firewalled? [Guessing here, I haven't ever used OpenWRT] –  derobert Oct 2 '12 at 6:23
    
BTW, once you type start typing a @-reply, you can tab-complete the nickname. I suggest this because I notice you spelled mine wrong (but thankfully the site notified me anyway...) –  derobert Oct 2 '12 at 6:24

2 Answers 2

@derobert is correct.

It is unaccessable because by default you cannot access the management web-page from the WAN interface. Only trusted devices (inside LAN) should be able to access the management interface.

share|improve this answer
    
Do you know how to configure firewall in my case? –  HelpNeeder Oct 2 '12 at 20:07
    
in the Administration section there is an option to enable management from WAN via http(s)/telnet/ssh/etc –  h3rrmiller Oct 3 '12 at 19:17
up vote 0 down vote accepted

File in /etc/ directory called firewall.user must be modified to allow port 22 to connect the router.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.