Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I can't continue until I solve this bug, I've tried removing the dpkg so it redownloads it but it still has this error when trying to dist-upgrade, or now, apt-get -f install.

root@hayek:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done

[Omitted outout]

The following NEW packages will be installed:
  cpp-4.6 gcc-4.6 libvlccore5 linux-headers-3.2.0-3-amd64 linux-headers-amd64
  The following packages will be upgraded:
  vlc vlc-data
  2 upgraded, 5 newly installed, 1 to remove and 486 not upgraded.
  1346 not fully installed or removed.
  Need to get 0 B/19.3 MB of archives.
  After this operation, 39.9 MB of additional disk space will be used.
  Do you want to continue [Y/n]? 

Reading changelogs... Done
(Reading database ... 204688 files and directories currently installed.)
Preparing to replace vlc 1.1.3-1squeeze6 (using .../vlc_1%3a2.0.3-dmo2_amd64.deb) ...
Unpacking replacement vlc ...
dpkg: error processing /var/cache/apt/archives/vlc_1%3a2.0.3-dmo2_amd64.deb (--unpack):
 trying to overwrite '/usr/share/doc/vlc', which is also in package vlc-data 1.1.3-1squeeze6
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/vlc_1%3a2.0.3-dmo2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

does anyone know what to do?

share|improve this question

2 Answers 2

Update: it appears the new vlc you're installing is from deb-multimedia.org. Per the deb-multimedia FAQ, you should send the bug report to marillat@free.fr.

First, you should report a bug. Squeeze to Wheezy upgrades should work without errors. You can do this easily with reportbug vlc. A quick glance at the VLC bug list doesn't show it, so please report. [The deb-multimedia packages should be set up such that reportbug should handle sending the report to Christian Marillat directly, instead of the Debian BTS, automatically. If not, you can save the report to a file, and mail it manually]

The error is complaining that you currently have a package vlc-data installed that contains the file /usr/share/doc/vlc, but the new vlc package also contains that file. So there is a conflict, which is causing dpkg to error out. Most likely, the wheezy version of vlc-data no longer contains this file (and the maintainer failed to tell dpkg to expect this situation). So the fixes are:

  • File the bug, wait for the maintainer to fix. May take a while, of course.
  • Try the official package instead of the deb-multimedia ones. Possibly then upgrade to the deb-multimedia ones after your system has been updated to Wheezy.
  • Attempt to upgrade vlc-data first, using dpkg -i on it (look in /var/cache/apt/archives, the .deb should be there). Then upgrade vlc. Dependencies may stop you here, but if not, this will work (and is very safe to do).
  • Remove vlc (and vlc-data, etc.) entirely. Then, when you reinstall them, it'll be installing the wheezy versions instead. This can be problematic if you have to remove a lot of packages due to dependencies.
  • Tell dpkg that you expect this error, and to continue anyway. Use dpkg --force-overwrite -i to install vlc (not vlc-data). The --force-overwrite is the key thing there. This is fairly safe, especially in this situation where you're pretty sure its just a file being moved between two related packages (and its /usr/share/doc after all).

Personally, when I run into this, after reporting the bug, I use ordering (e.g., vlc-data first) or --force-overwrite.

share|improve this answer
    
+1 a bug report needs to be filed. Since this break a release upgrade it would be release critical (unless he got vlc from the multimedia repos, then no one will care). –  jordanm Oct 1 '12 at 17:47
    
Not a Debian bug. Note the filename: vlc_1%3a2.0.3- dmo 2_amd64.deb. It is from debian.multimedia.org and nobody will care. –  Jim Paris Oct 1 '12 at 19:17
    
@JimParis Ah, you're right, the new one is indeed deb-multimedia.org. I'll update. –  derobert Oct 1 '12 at 21:08

I solved the problem with dpkg -r vlc.

share|improve this answer
    
This worked because there are two versions of VLC: the one you already had installed is from the official Debian repositories, and the new one you were trying to install is from the unofficial debian-multimedia.org repositories. They conflict with each other. You solved the problem by removing the first before installing the second, instead of trying to have them both installed at the same time. –  Jim Paris Oct 1 '12 at 19:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.