Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My computer has a SSD drive along with a HDD drive. I've installed Windows on the SSD drive (Intel) already and I would like to install Linux Mint on a partition created on the HDD hard drive. So I partitioned the HDD like so:

  • linux-swap
  • EXT4
  • FAT32 partition.

I installed Mint on the EXT4 partition, and when I restarted the computer, there is no GRUB! It starts Windows automatically without asking to choose the OS.

I'm assuming I have to do something with GRUB. Or no? I really don't want to mess up my Windows installation and start over. How do I fix this?

UPDATE:

my motherboard has a shortcut key F8 which if pressed during bootup, allows me to pick which hard drive to boot from and I've gotten to prefer this method over GRUB. This way I can install different OS's on separate hard drives without messing up my other installations (Thanks to cheap hard disk though!)

share|improve this question
    
Please don't judge me...I've been using linux on Vmware for a long time and I finally feel the need to go full blown Nixy. –  Armen B. Sep 29 '12 at 22:39
    
Cannot boot Linux Mint after installing Windows (First) and Linux Mint (Second) might also be of interest (though it doesn't suggest the easiest route here). –  Gilles Sep 29 '12 at 22:49
1  
SSD and SATA are not opposites. SSD is a storage technology, and SATA is an interface between a storage device and a computer. Many SSD's use SATA. You mean you have a SSD (solid-state drive) and a HDD (hard disk drive). –  cjm Sep 30 '12 at 0:02
    
Yes, absolutely You are right I meant HDD not SATA. –  Armen B. Sep 30 '12 at 0:40
    
Gilles - I looked into that, but that post suggests that Ubuntu finds the previous OS but mine doesn't. It doesn't even find the SSD Drive in order for me even to mount it. cjm - Yes, absolutely You are right I meant HDD not SATA. –  Armen B. Sep 30 '12 at 0:46
add comment

3 Answers

up vote 2 down vote accepted

You presumably have Grub installed on the hard disk, but your BIOS set to boot from the SSD. Either tell your BIOS to boot from the hard disk, or install Grub on the SSD.

My recommendation is to change the BIOS setting; that way each operating system lives completely independently on its own disk. In particular, you'll still be able to boot Windows if the hard disk fails. But if you wish to install Grub on the SSD, use a liveCD to boot into your Linux installation, and run sudo grub-install /dev/sda or sudo grub-install /dev/sdb, pick whichever of sda or sdb is the SSD (run the command df to see on what disks each operating system is located).

share|improve this answer
    
it would also be possible to use, e.g., gparted to shrink the NTFS partition on the SSD by a few hundred MB (enough for grub and a few kernels and initrd images), and use that space to create a new ext2 /boot partition on the SSD. –  cas Sep 29 '12 at 23:42
    
The problem is that the live CD (mint) doesn't locate the SSD drive and thus doesn't even find a previous OS installation (the windows 7). Also, when I set the BIOS to boot from the Hard disk, it says to set a proper drive with which has a boot. So there is no GRUB even when I set the BIOS to boot from the drive. –  Armen B. Sep 30 '12 at 0:43
add comment

If your firmware is UEFI rather than an old fashioned BIOS, you can use UEFI to directly boot your OSes without having to use GRUB. Both 64-bit Windows 7 and recent versions of Linux support UEFI booting.

share|improve this answer
    
Thanks for the suggestion I'll look into seeing if I can update my BIOS to UEFI but i doubt if it's available. My firmware is BIOS based currently. –  Armen B. Sep 30 '12 at 21:42
add comment

Excuse me, could you be more specific about what you did?

Do you have MBR or GPT installation? Is your FAT32 partition meant for backup of Windows, or it is EFI's EFI System Partition?

Did you use graphical installer of Mint to install to HDD? You made the partitions on HDD with GParted and told it to install GRUB? (GNU Parted <1.7.1 is known to remove first-stage bootloader from MBR in case of EFI/GPT scheme: http://www.rodsbooks.com/gdisk/booting.html)

Did you install GRUB-legacy or GRUB2? Assuming, you're using MBR scheme, did you install its 1,5-stage in case of GRUB-legacy, second-stage in case of GRUB2 in DOS-compatibility area/MBR-gap (31.5 kb between MBR and first partition) or right in filesystem? Consider related problems here: http://www.gnu.org/software/grub/manual/grub.html#BIOS-installation.

When did you install Windows on SSD? Before Linux or after that? Did Windows see or use HDD upon installation? (I'm asking, cause Windows is known to be harsh to other OSes, if installed second).

If you're no House M.D. and not obsessed with finding out the reason, but just want to solve the problem, in case of MBR scheme you could boot from Mint LiveCD/LiveUSB, mounted your HDD's ext4 partition to /mnt/sda1 (I suppose, it contains the root filesystem) and installed grub again with something like sudo grub-install --root-directory=/mnt/sda1 /dev/sda, where /dev/sda is your HDD device file. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.