Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have two logins on my box, one for work and the other for personal (I'm on crunchbang). Both run LXDE by default.

As of yesterday the work login started acting like an Openbox session, ie you had to hover over a window before you could enter text, the windows could not be dragged to another point on the screen and the maximise button wouldn't work.

The personal login, however, is working as expected and LXDE is as it should be. I can also log into a Xfce session and it is working fine (on work and personal logins) so the conflict appears to be between LXDE and Openbox.

The only thing that I can think I've done is to install a few packages from the repositories and to do an apt-get update.

If someone can tell me how to show the latest things installed from the repositories then I'll be able to tell you what they were.

I've tried removing (with the purge option) LXDE and reinstalling it but to no avail.

Can anyone think of a way for me to get LXDE working properly again? Are there any logs that I can trawl through to work out the problem? How do I find the last things installed from the repositories (so I can remove them)?

share|improve this question
    
/var/log/dpkg.log will show you what you've recently installed (grep install /var/log/dpkg.log). –  ire_and_curses Sep 29 '12 at 0:05
    
LXDE uses openbox as WM –  warl0ck Sep 29 '12 at 8:08
add comment

1 Answer

As warl0ck noted, LXDE uses openbox as the WM, so you may just have a problem in your configuration settings.

Hopefully these LXDE file locations should get you back on course:

  • The config files of LXPanel are stored in ~/.config/lxpanel/.
  • Under LXDE, we use a different profile name - LXDE. So it's in ~/.config/lxpanel/LXDE. In this way, if you changed the config of the panel under LXDE, it won't interfere other desktop environments.
  • If the config files are missing, lxpanel loads system-wide config in /usr/share/lxpanel/profile/ instead.
share|improve this answer
    
I don't know whether to mark your answer as accepted as I've not been able to solve the problem but thanks for your help (and warl0ck). It's given me more insight as to where to look/keep looking should anything happen to another DE. xfce here I come!!! –  user333913 Oct 1 '12 at 20:36
    
I'm sorry I couldn't help more. One way to get a better idea of the problem would be to start LXDE from the commandline. As a side note, you can find out the last 20 packages installed or updated by running this command ls -t /var/lib/dpkg/info/*.list | head -n 20 –  Sepero Oct 2 '12 at 9:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.