Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've got into a strange situation (because of my own stupidity of course:-)). I kept failing to install Chakra Linux from Live USB, so I was thinking that the reason could be that I created the Live USB the wrong way. So I tried to create Live USB directly using dd in the live version of Chakra, but I probably mispelled the path to my device and created the iso on one of my partitions. And now, when I try to boot from Live USB I get this error message:

:: Waiting for boot device…
:: /dev/disk/by-label/CHAKRA_201208 found, but the filesystem is unknown.  
Waiting 30 seconds for /dev/disk/by-label/ ...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty: job control turned off
[rootfs /]# 

How do I fix this situation? Is there a way to format my partitions from the rootfs prompt?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Change the boot order in the BIOS so that the USB stick is the first to test for a bootloader.

I missed the point with the labels.

If I don't miss anything you are in single user mode where you have the basic sbin and bin directories of root. There you should also find the basic commands like dd, ls and so on. Then you should be able to dd zeros onto /dev/disk/by-label/CHAKRA_201208.

The next option I would try is to boot from a CD or USB stick with a Linux installation which ignores any labels or other disk. After that you should be able to zero the disk again using the tool you like (dd with zero, shredder the disk, etc.). I think the Tails image should work.

share|improve this answer
    
I already have an USB device as a 1st boot option so this won't help me. –  Petr Mensik Sep 28 '12 at 19:29
    
It's booting with labels, so boot order won't matter. –  warl0ck Sep 29 '12 at 13:23
    
Thank you, that really worked. FYI- I was able to boot from Ubuntu too. –  Petr Mensik Sep 30 '12 at 17:05
add comment

You copied the whole fs, but linux doesn't mount iso9660 directly (but through fuse with userland helpers), so it fails.

Don't use DD to do the copy, the easiest way to create a live USB key is usbcreator-gtk in Ubuntu or Unetbootin;

My favorite way is copy iso files & setup grub2 manually on usb keys, that's a bit of difficult compare to the other two. But you got grub2 shipped.

share|improve this answer
    
Thanks for suggestion but I don't see how it helps me with my broken GRUB. But I will definitely try this next time. –  Petr Mensik Sep 30 '12 at 16:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.