Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to use 3 screens on my computers with 2 graphics card ATI Radeon HD 5450.

I've installed fglrx ATI drivers.

Here is the result of lspci :

root@dev1:~# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Cedar PRO [Radeon HD 5450]
06:00.0 VGA compatible controller: ATI Technologies Inc Cedar PRO [Radeon HD 5450]

And here is my xorg.conf

root@dev1:~# cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "Screen0" 0 0
    Screen      1   "Screen1" RightOf "Screen0"
    Screen      2   "Screen2" LeftOf "Screen0"
#   Option      "Xinerama" "true"
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "Monitor2"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Option      "ZaphodHeads" "VGA-0"
    Identifier  "Device0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      0
EndSection

Section "Device"
    Option      "ZaphodHeads" "DVI-0"
    Identifier  "Device1"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Screen      1
EndSection

Section "Device"
    Identifier  "Device2"
    Driver      "fglrx"
    BusID       "PCI:6:0:0"
    Screen      2
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Device0"
    Monitor    "Monitor0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Device1"
    Monitor    "Monitor1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen2"
    Device     "Device2"
    Monitor    "Monitor2"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

When I start the X server, it log this :

    root@dev1:~# /etc/init.d/kdm restart && tail -f /var/log/Xorg.0.log
Stopping K Display Manager: kdm...^[[Adone.
Starting K Display Manager: kdm.
xorg-server 2:1.7.7-14 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 28 17:59:07 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) ServerLayout "aticonfig Layout"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Screen "Screen1" (1)
(**) |   |-->Monitor "Monitor1"
(**) |   |-->Device "Device1"
(**) |-->Screen "Screen2" (2)
(**) |   |-->Monitor "Monitor2"
(**) |   |-->Device "Device2"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
(==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x7c8a40
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(++) using VT number 8

    (--) PCI:*(0:1:0:0) 1002:68f9:174b:e233 ATI Technologies Inc Cedar PRO  Radeon HD 5450] rev 0, Mem @ 0xe0000000/268435456, 0xf7e20000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
(--) PCI: (0:6:0:0) 1002:68f9:174b:e233 ATI Technologies Inc Cedar PRO [Radeon HD 5450] rev 0, Mem @ 0xd0000000/268435456, 0xf7d20000/131072, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.5.0, module version = 1.0.0
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.77.5
    Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.77.5
(II) ATI Proprietary Linux Driver Version Identifier:8.77.5
(II) ATI Proprietary Linux Driver Release Identifier: 8.771
(II) ATI Proprietary Linux Driver Build Date: Aug 25 2010 21:38:26
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) fglrx: No matching Device section for instance (BusID PCI:0@6:0:0) found
(--) Chipset Supported AMD Graphics Processor (0x68F9) found
(--) Chipset Supported AMD Graphics Processor (0x68F9) found
(--) Chipset Supported AMD Graphics Processor (0x68F9) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@6:0:1) found
(II) AMD Video driver is running on a device belonging to a group targeted for this release
(II) AMD Video driver is signed
(II) fglrx(0): pEnt->device->identifier=0x18d46c0
(II) fglrx(1): pEnt->device->identifier=0x18d46c0

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4667b8]
1: /usr/bin/X (0x400000+0x67d49) [0x467d49]
2: /lib/libpthread.so.0 (0x7f37d3167000+0xeff0) [0x7f37d3175ff0]
3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (atiddxProbe+0x7d6) [0x7f37cf6edb66]
4: /usr/bin/X (xf86CallDriverProbe+0x2bd) [0x47255d]
5: /usr/bin/X (InitOutput+0x343) [0x4729e3]
6: /usr/bin/X (0x400000+0x25a8a) [0x425a8a]
7: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f37d1c6ac8d]
8: /usr/bin/X (0x400000+0x257e9) [0x4257e9]
Segmentation fault at address 0x30

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
    at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Specially, I don't understand this line :

(WW) fglrx: No matching Device section for instance (BusID PCI:0@6:0:0) found

So could you help me to configure my xorg.conf to have 3 screens on 2 GPU ?

share|improve this question
    
Why do you have three device sections for two devices? –  terdon Sep 30 '12 at 14:54
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.