Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'd like to transfer files located on the harddrive of my laptop Acer Travelmate 4002 WLMi to my smartphone via bluetooth.

My system is Ubuntu 12.04.

I tried so far.

$ sudo service bluetooth start
bluetooth start/running, process 3315

$ sudo hcitool inq
Inquiring ...
Inquiry failed.: No such device

$ sudo rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

When I press the switch on the picture it won't turn on (yellow color). It's still turned off. In Windows OS it was possible to turn it on. enter image description here

Here, I have stuck. Do you know how to succeed in transferring files?

share|improve this question

2 Answers 2

You need to start bluetooth by:

service bluetooth start or start bluetooth, Otherwise hcitool would fail to contact the daemon.

To transfer files, use obexftp to do it (remember to pair before that)

share|improve this answer
    
I edited the question with your advice. –  xralf Sep 28 '12 at 11:34
    
@xralf launch those command as root –  warl0ck Sep 28 '12 at 11:34
    
OK, updated.... –  xralf Sep 28 '12 at 11:39
    
@xralf what about rfswitch, did you turn it off? –  warl0ck Sep 28 '12 at 11:44
    
I edited it again. Do you think the switch on the picture? –  xralf Sep 28 '12 at 12:01

Install blueman, it is an applet that will display an icon in your tray. Its context menu has a send files item and a add new device item, and a fairly straightforward settings window so you should be able to get it work out of the box.


In order for a user to add and manage Bluetooth devices using Blueman, the user must be added to the 'lp' group. It may be 'lpadmin' on Ubuntu/Debian.


Read /etc/dbus-1/system.d/bluetooth.conf for information about blueman user groups

share|improve this answer
    
+1 I use blueman for pairing too, but it sends files as text message which I don't like it –  warl0ck Sep 28 '12 at 12:19
    
I installed blueman and started blueman-manager. The command add new device is disabled (gray), I can't press it. –  xralf Sep 28 '12 at 12:31
    
Yes, the user is in lpadmin group. –  xralf Oct 4 '12 at 13:55
    
@xralf I just added one more section to the answer. Does it help you to see what user group might be probably missing? –  user13764 Oct 6 '12 at 0:05
    
The file looks as this. When I edit it and change the word lp to lpadmin it doesn't help. –  xralf Oct 6 '12 at 6:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.