Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Linux Mint 13 (Maya) on my Macbook Pro using rEFIt, and ran through the instructions here to get wireless working. Now I can see a bunch of different networks, but I almost always fail to connect to them. I get constant notificaitons that my wireless is disconnected, because it keeps trying to connect, to no avail.

The wireless actually has worked one or two times. About half the time I boot into Linux Mint, I am able to connect with wireless after maybe 5 minutes of struggling. Then I promptly lose it within minutes. What are the next steps to getting this worked out?

P.S. Wireless works with OS X so I know the network and my hardware is fine.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.