Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am emulating powerpc using qemu-system-ppc on top of x86, and running debian-lenny-ppc with it. I want to install kvm inside that debian. I have learned that the kvm and qemu-kvm packages are not available for the powerpc architecture.

I have found two packages (kvm-source and [Edit1]qemu) and installed it, but I don't know how to proceed with it further. How do I install kvm on powerpc? Do I need to cross-compile it as well, as given on http://www.linux-kvm.org/page/PowerPC_Host_Userspace?

[Edit1]:
Approach1: I downloaded qemu-kvm source code (http://sourceforge.net/projects/kvm/files/qemu-kvm/0.13.0/qemu-kvm-0.13.0.tar.gz/download) , configured

#./configure --target-list="ppc-softmmu" 
#make  

But I am getting this error:

CC    ppc-softmmu/virtio-pci.o
~/qemu-kvm-0.13.0/hw/virtio-pci.c: In function 'virtio_pci_mask_notifier':
~/qemu-kvm-0.13.0/hw/virtio-pci.c:436: error: invalid use of undefined 
type 'struct kvm_irq_routing_entry'
~/qemu-kvm-0.13.0/hw/virtio-pci.c:436: error: dereferencing pointer to 
incomplete type
share|improve this question
1  
Kvm on ppc is still experimental. I think you'll be better off getting it from upstream. –  Gilles Dec 16 '10 at 18:16
    
Holy crap, I had no idea Kvm was coming to powerpc! This gives our old G5 a whole new use!! –  Josh Dec 18 '10 at 18:07

2 Answers 2

up vote 1 down vote accepted


As Gilles suggested, why dont you try the details in the PowerPC_KVM link.
They have described the whole procedure there.


Added a Document on KVM on PowerPC .

Thanks,
Sen

share|improve this answer
    
thanks for your suggestion. I've already tried that approach and I am pasting the error in the question description. –  db42 Dec 20 '10 at 12:18
    
Why dont you just try giving "--with-patched-kernel" while configuring.. –  Sen Dec 20 '10 at 14:12
    
I believe the options you gave while configuring is minimal.. –  Sen Dec 20 '10 at 14:12
    
I tried qemu-kvm-0.11, and got it installed successfully. –  db42 Jan 9 '11 at 10:18

I successfully installed openSUSE 11.1 PPC on my PowerPC P5 9131-52A and compiled qemu 1.1.1 . You must have zlib and glib-2.2.4 before compiling. Then:

#./configure --target-list="ppc-softmmu ppc64_softmmu"
# make 
# make install

Be aware that after installing qemu you must uninstall glib-2.2.4 by doing make uninstall in the directory of glib-2.2.4 because otherwise some apps might break.

Then you can qemu-system-ppc -vnc :0 -hda DEBIAN.img -cdrom DEBIAN.iso -boot d and connect to :0 using a VNC client. But do note that it is very slow.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.