Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I’m trying to install a Canon Pixma MG4150 multifunction printer on Arch Linux 3.5.4-1-ARCH x86_64. The device is not working out of the box, I didn’t find anything about this printer on Google for a Linux system. Although, I found the PPD file for MG4100 (canonmg4100.ppd) and set it in CUPS, but it still doesn’t work. I tried to print the test page and a PDF document, the device doesn’t even react.

Here is the AUR packages I tried to install:

extra/libxpm 3.5.10-1
extra/pixman 0.26.2-1
aur/cnijfilter-mx410 3.50-1

The lsusb:

Bus 001 Device 003: ID 04a9:1753 Canon, Inc.

CUPS doesn’t show me any error messages but I don’t know if we can get any extra debug informations.

I don’t know what to do to get this printer working.

Thanks.

share|improve this question
add comment

1 Answer 1

The driver you installed is an older release (3.50) and built for the MX*** series. Try this one instead:

AUR :: cnijfilter-mg6200

It's using the same cnijfilter-source-3.60-1.tar.gz as the official .rpm or .deb CANON linux drivers for Pixma MG4150.

You should edit the PKGBUILD and replace (on line 2):

_model=mg6200

with

_model=mg4100
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.