Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Before I posted question here, I'd been hacking around for the solution for my problem, but none of them worked. Here is my situation. I had a Win7 OS before I put a Debian Squeeze on it, now I got a dual-boot. However, I tried both ways to install driver for my Nvidia Quadro 1000M card on this machine, Debian ways,

http://wiki.debian.org/NvidiaGraphicsDrivers 

and the Nvidia driver script from its website, both yielded the same result.

"failed to initialize the nvidia graphic device, none of the screen has been configured."(From var/log/Xorg.log)

and one thing I realized was that after tweaking the linux version of Nvidia driver from above, my windows Navidia driver broke as well when I logged into windows, and I had to reinstall to get it back working again. This seemed odd because they are on different partitions and filesystems. Does it mean that I can't get two drivers on the same machine even there are for different OSs and are in different partition? Or those above solutions only worked for standalone linux machine? Sorry about my incomplete knowledge for drivers, but please help cuz I am going nuts here. Thank you ini advance.

share|improve this question

1 Answer 1

up vote 2 down vote accepted
  1. installing the nvidia drivers on your linux partition will not affect your windows partition.

  2. the wiki page seems a bit outdated. try this:

    • install the linux-headers package for your kernel. on a 64-bit machine, that's likely to be just apt-get install linux-headers-amd64

    • install the dkms package apt-get install dkms

    • apt-get install nvidia-kernel-dkms DKMS will compile and install the nvidia module for your kernel version

    • you may need to update the initrd for your kernel so that the nvidia module gets loaded at boot rather than the nouveau driver update-initramfs -u -k $(uname r)

    • apt-get install nvidia-glx

    • configure X to use the nvidia driver rather than nv or nouveau. e.g. i have the following in my /etc/X11/xorg.conf:

    Section "Device"
        Identifier  "gtx560"
        Driver      "nvidia"
    
    
    Option "NoLogo" "True"
    Option "UseEvents" "True"
    
    EndSection Section "Screen" Identifier "Default Screen" Device "gtx560" Option "metamodes" "DFP: nvidia-auto-select +0+0" EndSection
    • load the newly compiled nvidia module rmmod nvidia ; modprobe nvidia

    • start your display manager, if you're using gdm3 that'll be /etc/init.d/gdm3 restart

Alternatively, ignore the last two steps and just reboot the machine.

All of the above should be done as root, preferably from a virtual console (e.g. press Alt-F1 - or Ctrl-Alt-F1 if you're in X and login). You can either login as root or login as yourself and then run sudo -i to get a root shell.

share|improve this answer
    
I want to thank you for this lengthy reply, but it still hasn't been working for me, I did follow your steps exactly and got the same answer, before I boot into the GUI OS, I got a black screen with a blinking like crazy cursor, the log from Xorg.log says "No devices detected and fatal server error: no screen found", what does it mean? Also, I discovered that if I got rid of xorg.conf in /etc/X11/, at least I could boot into system without stucking at the black screen and cursor, even though I can't use dual-display cuz it says X server is not configured. anyidea? Thank you –  Cong Hui Sep 23 '12 at 5:54
    
It's working after I disabled Nvidia optimus, screw them, Thank you again –  Cong Hui Sep 23 '12 at 6:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.