Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am a newbie to Linux. I am trying to add a webiste on Ubunutu Linux server and following this tutorial http://www.hostly.com/hosting-info/build-website-using-apache-1658.html

  • Created a webconfiguration file /etc/apache2/sites-available and it looks like this

    <VirtualHost *:80>
    # Basic setup
    ServerName analys.ideometrics.se
    DocumentRoot /home/micke/www/analys.ideometrics/
    # Logfiles
    ErrorLog  /home/micke/wwwlogs/apache2/error.log
    CustomLog /home/micke/wwwlogs/apache2/access.log combined
    </VirtualHost>
    
  • created a index.html in the location /home/micke/www/analys.ideometrics/

  • restarted apache webserver

when I am trying to access the URL (analys.ideometrics.se), getting internal error. I am not sure, if have to edit host file.

Can you please give me a clue. Thanks for your help !!

share|improve this question

migrated from serverfault.com Sep 21 '12 at 16:24

This question came from our site for professional system and network administrators.

    
What does the error say? –  BSull Sep 19 '12 at 21:48
    
Error : 500 Internal Server Error –  dotnetrocks Sep 19 '12 at 21:49
    
Internal server errors can mean a few different things. It looks like there is an error somewhere in the webserver configuration. Just check your logs (/home/micke/wwwlogs/apache2/error.log) to see what's causing the 500. –  Ben Ashton Sep 19 '12 at 21:55
    
I checked in log file, it didn't have any info about my http request. –  dotnetrocks Sep 19 '12 at 22:06
add comment

2 Answers

Did you follow step 7 of the guide you posted? Say your config file is /etc/apache2/sites-available/ideometrics, you must enable it using:

sudo a2ensite ideometrics

This creates a symlink in sites-enabled, which you can see by typing:

ls -l /etc/apache2/sites-enabled

It should read something like this:

lrwxrwxrwx 1 root root 27 Sep 28 10:51 ideometrics -> ../sites-available/ideometrics
share|improve this answer
    
This is the correct answer. –  bahamat Oct 22 '12 at 2:18
add comment

Put the VHost file in /sites-enabled and then restart apache.

share|improve this answer
    
Hi, webserver already has two other sites running with out problem. Do you still want me to try vhost file in /sites-enabled ? thanks. –  dotnetrocks Sep 19 '12 at 22:01
    
Does it hurt to try? It doesn't look like there is anything wrong with this vhost file so the problem lies either in where you put it or something else within apache. –  BSull Sep 19 '12 at 22:06
    
tried your idea, didn't work. thanks. –  dotnetrocks Sep 19 '12 at 22:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.