Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm a beginner in Linux and I'm having a problem installing wine I'm using RHEL 6.3 and when I use

yum install wine

it keeps giving me this

Blockquote Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.7.3)
Error: Package: wine-cms-1.4.1-1.el6.i686 (epel)
           Requires: liblcms.so.1
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libz.so.1
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.8)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.15)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: gnutls(x86-32)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.23)
Error: Package: wine-pulseaudio-1.4.1-1.el6.i686 (epel)
           Requires: alsa-plugins-pulseaudio(x86-32)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.2)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.21)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libglib-2.0.so.0
Error: Package: wine-alsa-1.4.1-1.el6.i686 (epel)
           Requires: libasound.so.2(ALSA_0.9)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libGLU.so.1
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.5.8)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libGL.so.1
Error: Package: wine-ldap-1.4.1-1.el6.i686 (epel)
           Requires: libldap_r-2.4.so.2
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgstreamer-0.10.so.0
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libX11.so.6
Error: Package: wine-alsa-1.4.1-1.el6.i686 (epel)
           Requires: libasound.so.2
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libXext.so.6
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libSM.so.6
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.5.7)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libusb-0.1.so.4
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgobject-2.0.so.0
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libICE.so.6
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libexif.so.12
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgphoto2_port.so.0
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.14)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libXrender(x86-32)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.4.30)
Error: Package: wine-alsa-1.4.1-1.el6.i686 (epel)
           Requires: libasound.so.2(ALSA_0.9.0rc4)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: freetype(x86-32)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgstapp-0.10.so.0
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgthread-2.0.so.0
Error: Package: wine-ldap-1.4.1-1.el6.i686 (epel)
           Requires: liblber-2.4.so.2
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libXcursor(x86-32)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgphoto2.so.2
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgmodule-2.0.so.0
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2(LIBXML2_2.6.0)
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libxml2.so.2
Error: Package: wine-core-1.4.1-1.el6.i686 (epel)
           Requires: libgstbase-0.10.so.0

I'v tried many things I'v installed epel and updated yum

I really could use some help guys thanks in advance

share|improve this question

1 Answer 1

You need to register your machine with RHN and make sure your subscription is current.

share|improve this answer
    
When i try to register it gives me this Problem registering system: Error communicating with server. The message was: Error Class Code: 70 Error Class Info: All available subscriptions for the requested channel have been exhausted. Please contact a Red Hat Network Sales associate. Explanation: An error has occurred while processing your request. If this problem persists please enter a bug report at bugzilla.redhat.com. If you choose to submit the bug report, please be sure to include details of what you were trying to do when this error occurred and –  abd el rhman Sep 20 '12 at 18:09
    
You let your subscription expire, or you never purchased a subscription. The server is no longer eligible to receive software from Red Hat. Contact Red Hat to renew your subscription. –  Michael Hampton Sep 20 '12 at 23:32
    
Many Thanks to you –  abd el rhman Sep 21 '12 at 7:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.