Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How would I go about installing glibc 2.5 on CentOS 4.8?

I know CentOS 4.8 has been EOL'd, which is all good and well. However, the environment that I am working in is using this version, and will be for a while. So, it's what I am stuck with.

I'm familiar with using yum, but not so familiar with using rpm.

share|improve this question
1  
If you are forced to stay with CentOS 4, you should go with the latest version - 4.9 –  Nils Sep 20 '12 at 20:13
add comment

1 Answer 1

up vote 2 down vote accepted

As a general rule, upgrading a package with rpm rather than yum is straight-forward: search for somewhere you can download a the RPM for centos from, download it and install it with rpm -i packagname.rpm. Alternatively download the source rpm, compile it under Centos 4.8 and install that (i.e. backport it - which is a fairly odd thing to do for glibc because glibc constitutes a large part of the environment that you are backporting to).

Repeat for any dependencies that the new glibc package may have - i.e. the new glibc may depend on newer version of other packages. (libc is likely to have several).

Repeat also for any currently installed packages that require the version of libc that comes with Centos 4.8 or are incompatible with the newer versions (you'll have to upgrade them to versions that are OK with a newer glibc). glibc is likely to have lots of these, and many of them will be other libraries.

These extra upgrades may in turn trigger another cycle of upgrades. and so on. for glibc, treat "may" as "will".

I think you need to ask yourself if you really want to do this. Your aims are contradictory - you want/need to stay with an older release of centos but you also want a newer libc. For some packages, that would be no big deal....but glibc is a core part of a linux system, changing it will affect just about every compiled executable on the system. Some will work just fine, and some will break outright with the newer glibc, and (worst of all) some will have subtly different - and wrong - behaviour or results.

This will lead to a situation where you have none of the benefits of staying with Centos 4.8 (e.g. well-known system and behaviour, all quirks and bugs have fixes/workarounds, no surprises, etc) AND where some/most/all of the benefits of upgrading to a newer version are offset by the fact that you're running a unique hybrid system - neither fish nor fowl. It won't be a hybrid with super mutant powers, it'll be a Frankenstein's Monster of ungainly mismatched parts.

In short, my recommendation is to either stick with what you've got or upgrade to the latest Centos 6.3. Sounds like you may have a fairly rigid change-management process at work, so that will require careful planning (always a good idea anyway) and written justification of the need to upgrade - including details of the problems that the old version is causing and the benefits that upgrading will provide.

Also, being able to demonstrate that any essential applications will work fine in the new Centos would be an invaluable supplement to the justification...so if you can, try booting up a 6.3 machine or VM and install your software on it.

share|improve this answer
    
Thanks for the explanation. Much appreciated. While I would love to upgrade the entire system, I don't have the authority to. This is for a web-application server (dedicated server from a web-host, strict OS and version rules), and it's running proprietary software which has been built against CentOS 4.8. That being said, I would love to have a new server to run this particular application on; however, it isn't an available option. :( –  Tim Sep 20 '12 at 14:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.