Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a headless Debian machine, with a Wifi dongle connected. I used to hide the Wifi AP, but now I can't.

If I unhide it, some lines in the /etc/network/interfaces will allow me to connect:

auto wlan0
iface wlan0 inet dhcp
        wpa-ssid <name>
        wpa-psk <hex/raw pwd>

If I hide the AP, add this line, then restart the interface, it won't work (DHCP gets no IP):

wpa-ap-scan 2

I've not found official documentation about the /etc/network/interfaces config.

What can I do now?

share|improve this question

I've not found official documentation about the /etc/network/interfaces config.

You can find the documentation at /usr/share/doc/wpasupplicant/README.Debian.gz. Under Chapter 4: Troubleshooting there's a section titled Hidden ssids:

In order to be able to associate to hidden ssids, please try to set the option 'ap_scan=1' in the global section, and 'scan_ssid=1' in your network block section of your wpa_supplicant.conf file. If you are using the managed mode, you can do so by these stanzas:

iface eth1 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    # ... additional options for your setup
share|improve this answer
up vote 7 down vote accepted

Finally, I've found out a solution, just an other line (previous not needed: wpa-ap-scan)

wpa-scan-ssid 1

I've not really found it in any documentation... just in a forum post.

share|improve this answer
    
I found this by guessing too, I used wpa-scan_ssid 1. Also works. – Matt Joiner Sep 5 '13 at 6:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.