Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have 4 versions of a file 1.21, 1.22, 1.23 and 1.24. After a month of time I came to know that the version 1.22 and 1.23 have some errors in them. Now I don't want anyone to use those versions. One way to solve it is to delete those versions, but I don't want to delete them. I just want to know a way so that if anyone checkout those obsolete versions they should get a warning or custom message that "don't use this version, this version has some problems".

Is there any way to do this? Let me know, thanks.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

CVS has no such function.

If you don't want to change the file itself, you have to modify whatever points to those revisions (tags, documentation etc.).

share|improve this answer
add comment

As @CL says, there is no function to do this.

What I would encourage, and I have seen this in many places, is to add not only a comment in a revision notice text file, but also a file titled "faulty_deprecated-do_not_use.txt" or similar as part of the distribution/package to help make it as obvious as possible.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.