Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've Asus UEFI motherboard with 2 hard disks, (hd0) and (hd1).

I managed to make my Debian Wheezy on my second disk bootable using grub-efi and it boots OK. I also have Windows on the first disk, which isn't unbootable but the way I have to do it is unconvenient.

The problem is that when I boot from the EFI firmware, choosing the Debian-Grub2 boot entry from the colourful menu, GRUB2 can see (using ls and anything else) both disks, but when I do nothing after turning PC on and just wait for the Grub menu to appear on its own (it has the highest priority among EFI menu boot entries) and then try to boot my Windows (using console or having added Grub menu entry), it just doesn't see the first disk and names the second one (hd0), so the attempt fails.

My guess is that the EFI firmware somehow doesn't tell GRUB there is the first disk, maybe for speeding up. I use LVM if it matters.

How to make GRUB2 see both disks?

share|improve this question
    
Why are you using grub? The EFI firmware already includes a boot manager which lets you select either Windows or Debian. You don't need grub. –  Marco Sep 16 '12 at 20:16
    
This might be relevant: Setting up Debian on UEFI –  Marco Sep 17 '12 at 7:35
    
@Marko thank you for the information, I didn't know of such a possibility and it's useful, but 1) building kernel and a newer one than even in the testing Debian distro just isn't the "Debian" reliable way, I suppose :) 2) I've spent with the Wheezy/Grub2/EFI mix so much time that we became somewhat close (if u know what I mean)) and I want to finish the loader with my own two hands) it's also interesting; 3) now that both systems are bootable and working it seems too dangerous to tinker with them on the level you're talking about –  alexey Sep 17 '12 at 12:34
    
2) This combination and the hours spend on Grub2/EFI was what made me eventually drop Grub. The boot process is faster and easier maintainable with just one boot manager (UEFI). 3) If you have a backup and a bootable USB drive what can happen in the worst case? Good luck! –  Marco Sep 17 '12 at 13:00
add comment

1 Answer 1

up vote 0 down vote accepted

It looks like the problem is solved. I just disabled the "fast boot" (or sth equivalent) option at the EFI motherboard menu during boot process. As a result of the optimization EFI made to speed up booting, incomplete device map seems to be passed to bootloader - with information about just the target OS hard disk.

GRUB used to see all the disks even with the option being on if I entered the EFI menu and chose to boot GRUB from it, so apparently, the optimization only affects direct boots, those avoiding the menu. May be sensitive if you have large '> 1 TB' disks with numerous partitions for EFI to look through.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.