Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a USB inkjet printer connected to a server running CentOS 5.7 (64). I installed and enabled cups-lpd so that another Unix server could send print jobs to that printer.

The other Unix server assumes you want a banner page printed unless you use the -o nobanner option on it's lp command but I have an application there that uses lp but has no way to specify that option.

Consequently, the LPD transacion includes a "Print banner page" option (RFC1179 section 7.5) - at least I'm fairly sure (though I haven't checked with tcpdump etc)

The result is I get an unwanted page saying "Cover Page" in big letters and giving Job-Id, Title and User name. This serves no purpose in my environment.

Is there any way to configure cups-lpd to ignore this "print banner page" flag?


Update: Here's the start of /etc/cups/printers.conf

# Printer configuration file for CUPS v1.3.7
# Written by cupsd on 2012-09-13 15:43
<Printer inkjet1>
Info HP PSC 2210
Location Ground FLoor, Outlet  A3/A4
DeviceURI usb://HP/PSC%202200%20Series?serial=XXXXXXXXXXXXXXX
State Idle
StateTime 1347547335
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>
share|improve this question

3 Answers 3

try moving the contents of the /usr/share/banners to a tar and leaving /usr/share/banners empty. I did that and now the banners never print.

share|improve this answer
    
-1 for advocating manually messing around in /usr. This is almost never a good idea. –  HalosGhost Jun 14 at 0:20
up vote 1 down vote accepted

From man cups-lpd, I discovered you can add

  server_args = -o job-sheets=none,none

to /etc/xinetd/cups-lpd and then ask xinetd to reload it's configuration (sudo /sbin/service xinetd reload)

Note: I ran lpoptions -d printername to discover this print option but have not found anywhere it is fully documented (e.g. what each of the two "none"s refer to). The allowed values for this "job-sheets" option are documented at cups.org

Obviously, this solution applies to all printers rather than a specific printer.

share|improve this answer

Edit your /etc/cups/printers.conf and set the printer's JobSheets :

JobSheets none none
share|improve this answer
    
When I edited /etc/cups/printers.conf all the <Printer printername> sections already contained JobSheets none none - It looks like it isn't obeyed for some reason. –  RedGrittyBrick Sep 14 '12 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.