Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been setting up a new CrunchBang Linux and my sound doesn't work. When I type lspci -v command and alplay -l command in command prompt I can see that my sound card is connected and detected.

Results:

ziga@ziga-laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: HDA Generic [HDA Generic]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

More results:

ziga@ziga-laptop:~$ lspci -v
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
    Subsystem: Hewlett-Packard Company Device 1604
    Flags: bus master, slow devsel, latency 64, IRQ 16
    Memory at 90400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel

Well I've figured out that my audio card model is ATI SBx00 and I can't find it on www.alsa-project.org although my soundcard already worked with alsamixer when I was using Xubuntu 12.04. And it also worked with previous versions of CrunchBang Linux. So I've tried to reconfigure alsamixer by using command alsamixer, pressing F5 and then increasing all sliders to the max like shown below.

┌───────────────────────────── AlsaMixer v1.0.23 ──────────────────────────────┐
│ Card: HDA ATI SB                                     F1:  Help               │
│ Chip: Realtek ID 270                                 F2:  System information │
│ View: F3: Playback  F4: Capture  F5:[All]            F6:  Select sound card  │
│ Item: PCM [dB gain: 0.00, 0.00]                      Esc: Exit               │
│                                                                              │
│                       ┌──┐     ┌──┐     ┌──┐     ┌──┐                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       │▒▒│     │▒▒│     │▒▒│     │▒▒│                        │
│                       └──┘     └──┘    L└──┘R    └──┘                        │
│                                       CAPTURE                                │
│                     100<>100 100<>100 100<>100 100<>100                      │
│                      Master <  PCM   >Capture  Digital                       │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

When in alsamixer i tried to hit F2 and this menu pops out:

┌───── Select File ──────┐
│/proc/asound/version    │
│/proc/asound/cards      │
│/proc/asound/devices    │
│/proc/asound/oss/devices│
│/proc/asound/timers     │
│/proc/asound/pcm        │
└────────────────────────┘

Below i will paste outputs of all of all menu options, here it goes:

┌───────────────── /proc/asound/version ─────────────────┐          
│Advanced Linux Sound Architecture Driver Version 1.0.21.│          
└────────────────────────────────────────────────────────┘          
┌──────────────── /proc/asound/cards ─────────────────┐            
│ 0 [SB             ]: HDA-Intel - HDA ATI SB         │            
│                      HDA ATI SB at 0x90400000 irq 16│            
└─────────────────────────────────────────────────────┘            
┌─────── /proc/asound/devices ───────┐                  
│  2:        : timer                 │                  
│  3:        : sequencer             │                  
│  4: [ 0- 0]: digital audio playback│                  
│  5: [ 0- 0]: digital audio capture │                  
│  6: [ 0- 0]: hardware dependent    │                  
│  7: [ 0]   : control               │                  
└────────────────────────────────────┘       
┌ /proc/asound/oss/devices ┐
│  0: [0- 0]: mixer        │
│  3: [0- 0]: digital audio│
│  4: [0- 0]: digital audio│
└──────────────────────────┘
┌──────────── /proc/asound/timers ─────────────┐               
│G0: system timer : 4000.000us (10000000 ticks)│               
│P0-0-0: PCM playback 0-0-0 : SLAVE            │               
│P0-0-1: PCM capture 0-0-1 : SLAVE             │               
└──────────────────────────────────────────────┘               
┌─────────────────── /proc/asound/pcm ────────────────────┐          
│00-00: HDA Generic : HDA Generic : playback 1 : capture 1│          
└─────────────────────────────────────────────────────────┘        

When i press F6 i get the menu for selecting sound card which looks like this:

┌───── Sound Card ──────┐
│-  (default)           │
│0  HDA ATI SB          │
│   enter device name...│
└───────────────────────┘
share|improve this question
    
I just found out that my soundcard works if i plug in my headphones, but it doesn't work if i unplug them. –  71GA Sep 14 '12 at 13:06
    
Which version of CrunchBang, and which audio codec, are you using? –  CL. Sep 14 '12 at 13:35
    
I have a CrunchBang v 2.6.32.5-amd64 and alsamixer is version 1.0.23. –  71GA Sep 14 '12 at 14:08
    
Do check if your audio works after a cold boot, BEFORE you start X-Server. –  darnir Sep 18 '12 at 15:14
    
Not yet. How can i do that? –  71GA Sep 18 '12 at 15:20
show 2 more comments

4 Answers 4

up vote 3 down vote accepted
+50

Try F5 in alsamixer.

you will see All possible options. maybe there is something muted by default.

what do you see pressing F2 and F6?

share|improve this answer
    
I did edit my post according to your suggestions. –  71GA Sep 18 '12 at 11:54
add comment

Kernel 2.6.32 is from 2009; you cannot expect that old drivers to work with newer hardware.

Try to get a newer CrunchBang kernel, or switch to another distribution.

share|improve this answer
    
I have installed kernel 3.5 packed with Arch Linux distribution and i get a the same error. This must be some sort of a bug. I ve seen many threads complaining about this on other forums and no solution exists yet. –  71GA Sep 16 '12 at 23:34
    
changing the whole distro because of a currently not so proper working audio device seems like a very Windowish solution [reboot, else reinstall]. –  erch Jun 12 '13 at 19:40
add comment

Kindly look into these two links which people have frequently used to solve their audio related problems after installing Ubuntu 12.04 PP (including me) . Here they are :

http://ubuntuforums.org/showthread.php?t=1042840

http://yourenotabowler.blogspot.in/2009/01/sound-warz.html

Look at the second link for this one has helped me a lot for fixing similar kind of issue in my HP laptop.

Hope this helps you .

share|improve this answer
add comment

It sounds like you are missing a sound module. Here are some ideas you can try:

  • Since the soundcard is correctly detected (your headphones work), it sounds like you are either missing the module that controls the pc speakers, or you have the speakers muted. Have you tried switching devices by hitting F6 in alsamixer? If you switch from default to 0 HDA ATI SB, you may get more options. On my system, I get many more channels, including "Front". Make sure that "Front" is set to maximum volume.

  • The alsa-info.shscript should give you some more useful information. Try running it and linking to its output please:

    $ wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh
    

    That way we can check what modules you have loaded and if anything is missing.

  • alsaconf is a script to configure alsa. Although it is no longer included in the alsa-utils package, it may still be worth looking into. I found an old version here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.